Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1204623 - emacs and editing features do not function under SWI-prolog
Summary: emacs and editing features do not function under SWI-prolog
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pl
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 08:33 UTC by Sean A. Fulop
Modified: 2015-04-22 10:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-03 11:12:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Sean A. Fulop 2015-03-23 08:33:00 UTC
Description of problem:
When running swipl, attempted built-in command emacs provides an error that the predicate emacs/0 does not exist.

Furthermore, attempt to use the commmand edit(filename) also returns an error.  Jan Wielemaker has confirmed that this behaviour signifies an improper package build.


Version-Release number of selected component (if applicable):
pl-6.4.1 fc20

How reproducible:


Steps to Reproduce:
1. run swipl
2. try command emacs
3. try command edit(filename)

Actual results:
Errors, commands do not perform

Expected results:
command emacs is supposed to launch the GUI pce-emacs integrated development environment

command edit(filename) is supposed to launch whichever text editor is set as default in swipl; neither command should provide an error


Additional info:

Comment 1 Petr Pisar 2015-04-03 11:12:52 UTC
Executing editor works for me:

?- edit(file('new')).
% Waiting for editor ... 
% Running make to reload modified files
true.

It spawns vim, which is my $EDITOR, on `new' file.

If I install `pl-xpce' package which brings your desired GUI, then it will spawn an XPCE editor. Also if `pl-xpce' package is installed, emacs goal will be available and it spawn XPCE with an Emacs imitiation.

The XPCE is not part of the `pl' package because not all SWI Prolog users needs XPCE or even does not have X server available.

Comment 2 Sean A. Fulop 2015-04-22 07:11:29 UTC
OK I see.  Here is the text that appears in YUM to document the contents of the pl rpm package:

ISO/Edinburgh-style Prolog compiler including modules, auto-load,
libraries, Garbage-collector, stack-expandor, C/C++-interface,
GNU-readline interface, very fast compiler.  Including packages clib
(Unix process control and sockets), cpp (C++ interface), sgml (reading
XML/SGML), sgml/RDF (reading RDF into triples) and XPCE (Graphics UI
toolkit, integrated editor (Emacs-clone) and source-level debugger).


Notice that it states XPCE is included in the pl package.  I had no idea to install a separate package to get it.  I think this documentation should be changed to state that pl-xpce is a separate package.

Comment 3 Petr Pisar 2015-04-22 10:32:58 UTC
Fair enough. I updated the pl's package description in pl-6.6.6-6.fc23. As this is very low severity issue, it will get into older Fedoras only if another update will be necessary there.


Note You need to log in before you can comment on or make changes to this bug.