Bug 1204631 - [origin_runtime_664] Should show help info when using "osc project --help"
Summary: [origin_runtime_664] Should show help info when using "osc project --help"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 08:51 UTC by Meng Bo
Modified: 2015-05-15 03:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 18:00:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meng Bo 2015-03-23 08:51:41 UTC
Description of problem:
The project command should print out the usage when the --help option specified.

Version-Release number of selected component (if applicable):
openshift v0.4.1-247-g767aea7
kubernetes v0.12.0-992-gc5f7351


How reproducible:
always

Steps to Reproduce:
1. Setup openshift env
2. Try to get the help info about the osc project command
$ osc project --help
3.

Actual results:
It will ignore the --help option and no help printed.

Expected results:
Should give the help info about this command.

Since the following line shows in the osc --help
Use "osc <command> --help" for more information about a given command.

Additional info:
[vagrant@openshift-master ~]$ osc project --help
No specific project in use.
[vagrant@openshift-master ~]$ osc project default
Now using project 'default'.
[vagrant@openshift-master ~]$ osc project --help
Using project 'default'.
[vagrant@openshift-master ~]$ osc project 
Using project 'default'.

Comment 1 Fabiano Franz 2015-04-01 15:23:19 UTC
Fixed in master.

Comment 2 Meng Bo 2015-04-02 07:50:00 UTC
$ osc project --help
Switch to another project and make it the default in your configuration.

Options:
  -h, --help=false: help for project

Use "osc --help" for a list of all commands available in osc.


Issue fixed with version:
openshift v0.4.2-73-g11f00ab-dirty
kubernetes v0.13.1-dev-641-gf057a25


Note You need to log in before you can comment on or make changes to this bug.