Bug 1204637 - slow group operations
Summary: slow group operations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks: 1019272 1187824
TreeView+ depends on / blocked
 
Reported: 2015-03-23 09:22 UTC by Petr Vobornik
Modified: 2019-09-12 08:19 UTC (History)
6 users (show)

Fixed In Version: ipa-4.2.0-0.1.alpha1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 12:02:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
ipa-group-show (519.89 KB, text/plain)
2015-09-15 07:04 UTC, Abhijeet Kasurde
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2362 0 normal SHIPPED_LIVE ipa bug fix and enhancement update 2015-11-19 10:40:46 UTC

Description Petr Vobornik 2015-03-23 09:22:42 UTC
Description of problem:
Operations with groups which have a lot of users, e.g. 15K, are very slow in IPA management framework- both CLI and Web UI.

`ipa group-find` and `ipa group-show` calls takes a lot of resources in httpd process. The computation takes a lot of time(120s) so CLI will time out. In Web UI, when it finally receives the data, internal computations to render group members takes also a lot of time(e.g. 8s).

Version-Release number of selected component (if applicable):
3.x - 4.x (every)

How reproducible:
always

Steps to Reproduce:
1. create IPA instance with 15K+ users in ipausers group
2. call `ipa group-show ipausers`

Actual results:
Hi server load, CLI timeout.

Expected results:
CLI will print result in timely fashion.

Comment 2 Petr Vobornik 2015-03-23 09:32:05 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4947

Comment 3 Petr Vobornik 2015-03-26 11:58:48 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4965

Comment 4 Petr Vobornik 2015-04-14 17:09:14 UTC
Ticket #4948 is also related - removes member fetching in comboboxes in Web UI

master:
https://fedorahosted.org/freeipa/changeset/efcd48ad01a39a67f131a2cea9d54771642222fb

Comment 5 Petr Vobornik 2015-04-14 17:36:04 UTC
Related faster DN implementation:

master:
https://fedorahosted.org/freeipa/changeset/11bd9d96f191066f7ba760549f00179c128a9787

Comment 7 Petr Vobornik 2015-04-21 14:55:49 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4995

Comment 8 Jan Cholasta 2015-04-27 05:58:33 UTC
Ticket 4947 fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/4364ac08c538e3a4253804f523707092b34c2ed2

Comment 9 Petr Vobornik 2015-05-12 09:01:04 UTC
Faster Web UI:

master:
* 68f04643d6022707e8ccac9f8b817542d9022119 jQuery.ordered_map: faster creation
* 60997b58b88fd5e82663857f94ced7544d0220cc jQuery.ordered_map: remove map attribute

Comment 10 Martin Kosek 2015-05-21 13:11:55 UTC
https://fedorahosted.org/freeipa/ticket/4995 was postponed upstream, removing from this bug.

Tickets 4947 and 4965 are done, so moving the Bug to POST.

Comment 14 Abhijeet Kasurde 2015-09-15 07:04:44 UTC
Created attachment 1073517 [details]
ipa-group-show

Comment 15 Abhijeet Kasurde 2015-09-15 07:08:13 UTC
Verified fix using IPA server 4.2.0.

See log file for performance timings.

CLI like group-show, group-find provides result for 20K+ users in ~4-5 secs
WEB Users groups provides result for 20K+ users in ~8-10 secs.

Comment 16 errata-xmlrpc 2015-11-19 12:02:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html


Note You need to log in before you can comment on or make changes to this bug.