Bug 120469 - Installs of extensions fail as normal user
Summary: Installs of extensions fail as normal user
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 01:57 UTC by Tom London
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-12 19:05:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2004-04-09 01:57:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Attempts at installing certain extensions succeed if running mozilla
as root, but fail otherwise.

For example, attempts at installing "home button", "banner blind", or
"jre" seem to work as root, but fail with various error messages.
(home button fails with "chrome registration failed").

Here is a snippet from the install.log:
-------------------------------------------------------------------------------
file:///home/tbl/Download/mozExtensions/home.xpi  --  04/08/2004 18:44:28
-------------------------------------------------------------------------------
 
     Home Button (version 0.6)
     -----------
 
     [1/4]      Installing:
/home/tbl/.mozilla/Pass1/etitruej.slt/chrome/home.jar
     [2/4]      Register Content:
jar:file:///home/tbl/.mozilla/Pass1/etitruej.slt/chrome/home.jar!/content/
     ** opening of installed-chrome.txt failed. - nsresult code:
0x80520015
     ** /usr/lib/mozilla-1.6/chrome/installed-chrome.txt
     ** opening of installed-chrome.txt failed. - nsresult code:
0x80520015
     ** Failed to register chrome. - nsresult code: 0x80520015
 
     Install **FAILED** with error -239  --  04/08/2004 18:44:32


Version-Release number of selected component (if applicable):
mozilla-1.6-2

How reproducible:
Always

Steps to Reproduce:
1. download home.xpi from mozdev.org
2. start mozilla as non-root
3. File->Open File... home.xpi
    

Actual Results:  installation fails as normal user, but succeeds as root.

Expected Results:  successful installation

Additional info: (Installion of some other extensions succeed:
adblocker, ...)

Comment 1 Christopher Blizzard 2004-04-12 19:05:24 UTC
I can't fix this since this is a problem with the package.  It assumes
that it can be installed into the system directory.

Comment 2 Tom London 2004-04-12 19:17:47 UTC
hmmm... it asks whether to install in profile for system directory.  I
replied profile.

I'm guessing it is still trying to open something in the system
directory (/usr/lib/mozilla-1.6/....)

This is going to be a interesting challenge getting extension
developers to behave ......


Note You need to log in before you can comment on or make changes to this bug.