Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1204727 - Maintainin local transaction peer list in op-sm framework
Summary: Maintainin local transaction peer list in op-sm framework
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1206429
TreeView+ depends on / blocked
 
Reported: 2015-03-23 12:22 UTC by Atin Mukherjee
Modified: 2015-05-14 17:46 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1206429 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:29:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2015-03-23 12:22:53 UTC
Description of problem:

Just like sync-op in glusterd, op-sm framework also demands maintaining local transaction peer list as concurrent op-sm transactions may corrupt the global peer list just like what we observed in https://bugzilla.redhat.com/show_bug.cgi?id=1173414

Comment 1 Anand Avati 2015-03-23 12:27:29 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain per transaction xaction_peers list in op-sm) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2015-03-24 06:11:37 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain local xaction_peer list for op-sm) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Anand Avati 2015-03-24 06:46:34 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain local xaction_peer list for op-sm) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Anand Avati 2015-03-24 06:58:45 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain local xaction_peer list for op-sm) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Anand Avati 2015-03-24 09:05:31 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain local xaction_peer list for op-sm) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Anand Avati 2015-03-24 09:05:39 UTC
REVIEW: http://review.gluster.org/9980 (glusterd: clean up global xaction peer occurances) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Anand Avati 2015-03-25 04:57:42 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain local xaction_peer list for op-sm) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 8 Anand Avati 2015-03-25 05:21:06 UTC
REVIEW: http://review.gluster.org/9972 (glusterd: Maintain local xaction_peer list for op-sm) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 9 Anand Avati 2015-03-25 05:21:09 UTC
REVIEW: http://review.gluster.org/9980 (glusterd: clean up global xaction_peer occurances) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 10 Anand Avati 2015-03-26 07:10:50 UTC
COMMIT: http://review.gluster.org/9972 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 087ad8a001c77ec9703a0a74256819cf99cc31d4
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Tue Mar 24 11:27:52 2015 +0530

    glusterd: Maintain local xaction_peer list for op-sm
    
    http://review.gluster.org/9269 addresses maintaining local xaction_peers in
    syncop and mgmt_v3 framework. This patch is to maintain local xaction_peers list
    for op-sm framework as well.
    
    Change-Id: Idd8484463fed196b3b18c2df7f550a3302c6e138
    BUG: 1204727
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/9972
    Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 11 Anand Avati 2015-03-26 07:12:37 UTC
COMMIT: http://review.gluster.org/9980 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 7cd58994262d2d622c1533c6f7a905106a1cf197
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Wed Mar 25 10:39:20 2015 +0530

    glusterd: clean up global xaction_peer occurances
    
    With http://review.gluster.org/#/c/9972/ there is no more need to maintain
    xaction_peers in glusterd_conf_t. This patch cleans up code for all the
    occurances of xaction_peers.
    
    Change-Id: I4fbf2df0fa9b8a8751029be36be7f76f6464cc76
    BUG: 1204727
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/9980
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 12 Anand Avati 2015-03-26 07:47:49 UTC
REVIEW: http://review.gluster.org/10006 (glusterd: clean up global xaction_peer occurances) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)

Comment 13 Anand Avati 2015-03-26 08:01:02 UTC
REVIEW: http://review.gluster.org/10006 (glusterd: clean up global xaction_peer occurances) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)

Comment 14 Anand Avati 2015-03-27 04:00:16 UTC
COMMIT: http://review.gluster.org/10006 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit c8a723ac7cbd7bdc8bd01350c56e15fd7fa5e7ca
Author: anand <anekkunt@redhat.com>
Date:   Thu Mar 26 13:15:48 2015 +0530

    glusterd: clean up global xaction_peer occurances
    
    Remove xaction_peers from glusterd_conf_t which was left out by
    http://review.gluster.org/#/c/9980/ patch
    
    Change-Id: I8494ec181ec11922861d7bad12c46d45e036637b
    BUG: 1204727
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/10006
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 15 Anand Avati 2015-03-28 15:43:01 UTC
REVIEW: http://review.gluster.org/10032 (glusterd : fix memory overrun for opinfo.local_xaction_peers) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 16 Anand Avati 2015-03-30 02:40:32 UTC
COMMIT: http://review.gluster.org/10032 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit d5a9607598cf02e50bce306cffe97990a50129c0
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Sat Mar 28 21:09:57 2015 +0530

    glusterd : fix memory overrun for opinfo.local_xaction_peers
    
    Due to incorrect sizeof local_xaction_peers was not allocated as intended which
    lead a memory overrun in gf_free while freeing local_xaction_peers.
    
    Change-Id: Ie4d63289aae51727eea091bce0e6cb0a496ce7cf
    BUG: 1204727
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/10032
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Emmanuel Dreyfus <manu@netbsd.org>
    Tested-by: Emmanuel Dreyfus <manu@netbsd.org>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 17 Niels de Vos 2015-05-14 17:29:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 18 Niels de Vos 2015-05-14 17:35:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 19 Niels de Vos 2015-05-14 17:38:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 20 Niels de Vos 2015-05-14 17:46:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.