Bug 120473 - sk98lin network driver kernel oops on load (boot)....nic unusable
sk98lin network driver kernel oops on load (boot)....nic unusable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 23:08 EDT by Jerone Young
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 20:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerone Young 2004-04-08 23:08:17 EDT
Description of problem:
Since kernel-2.6.4-303 to this new kernel-2.6.6-1.308 some redhat
patch to the kernel is causing the sk98lin driver to die! And who
knows what else. Here is the dump:

sk98lin: Network Device Driver v6.23
(C)Copyright 1999-2004 Marvell(R).
divert: allocating divert_blk for eth0
eth0: 3Com Gigabit LOM (3C940)
      PrefPort:A  RlmtMode:Check Link State
divert: freeing divert_blk for eth0
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at generic:660
invalid operand: 0000 [1]
CPU 0
Pid: 987, comm: modprobe Not tainted 2.6.5-1.308
RIP: 0010:[<ffffffff801c8fda>] <ffffffff801c8fda>{remove_proc_entry+197}
RSP: 0018:000001003a109ec8  EFLAGS: 00010206
RAX: 0000000000000001 RBX: 000001003a1d3380 RCX: 0000000000000000
RDX: 000001003a1d3380 RSI: 000001003a1d340f RDI: 000001003a1d3380
RBP: 0000010001e71be0 R08: 000001003a108000 R09: 000001003a60d100
R10: 000001003a60d100 R11: 0000000000000000 R12: 000001003a1d3408
R13: 0000000000000007 R14: 000000000040e9a0 R15: 00000000005380e8
FS:  0000002a9556b4c0(0000) GS:ffffffff804ec580(0000)
knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000003a6128ca90 CR3: 0000000000101000 CR4: 00000000000006e0
Process modprobe (pid: 987, stackpage=1003ed57a80)
Stack: 0000000000000000 0000010001e71b80 000001003a1d3408 ffffffffa0119f80
       ffffffff8041f300 0000000000000000 0000000000000080 ffffffff80152951
       0000000000000001 0000000001e73ac0
Call Trace:<ffffffff80152951>{sys_delete_module+319}
<ffffffff80172dc8>{do_munmap+639}
       <ffffffff80172e1a>{sys_munmap+69}
<ffffffff8011196e>{system_call+126}
                                                                     
                                   
                                                                     
                                   
Code: 0f 0b 61 28 35 80 ff ff ff ff 94 02 8b 83 80 00 00 00 85 c0
RIP <ffffffff801c8fda>{remove_proc_entry+197} RSP <000001003a109ec8>
 ip_tables: (C) 2000-2002 Netfilter core team
Linux Kernel Card Services


Now my network card is unusable with these jacked up redhat kernels.
But the kernel.org kernel works fine. PLEASE FIX!!!

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.308

How reproducible:
Always

Steps to Reproduce:

    

Additional info:

My system config:
Asus K8V motherboard (integrated 3com 3C940 netowrk card)
Athlon 64 3200+
1 Gig RAM
Comment 1 Sahil Verma 2004-04-09 13:42:25 EDT
Dupe of 118546.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118546
Comment 2 Jerone Young 2004-04-09 14:05:14 EDT
This is not a dupe of 118546. Unlike that bug this bug doesn't even
allow you to load up the module in the first place. Plus I able to
load up the modules in kernel-2.6.4-300. It wasn't till
kernel-2.6.4-303 that all this started happening...I was hopping it
would be fixed when FC2 switched to 2.6.5 , and someone whould see
this. But it looks like it is a Redhat patch to the kernel that is
causing this, because the kernel.org 2.6.4 & 2.6.5 don't have this issue! 
Comment 3 Sahil Verma 2004-04-09 15:18:16 EDT
Identical EIP and backtrace.
Comment 4 Jerone Young 2004-04-14 20:47:03 EDT
Fixed in kernel-2.6.4.322. 

                 Thanks!
Comment 5 Jerone Young 2004-04-14 20:47:37 EDT
I meant kernel-2.6.5-322

Note You need to log in before you can comment on or make changes to this bug.