Bug 120475 - sleep_on referenced by reserfs.ko but not provided by a kernel
sleep_on referenced by reserfs.ko but not provided by a kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 00:02 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 326
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 04:57:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-04-09 00:02:41 EDT
Description of problem:

# depmod -e -F /boot/System.map-2.6.5-1.308smp 
WARNING:/lib/modules/2.6.5-1.308smp/unsupported/fs/reiserfs/reiserfs.ko
needs unknown symbol sleep_on

Messages like that show up also during a kernel installation.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.308, kernel-smp-2.6.5-1.308
Comment 1 Cott Lang 2004-04-09 10:59:40 EDT
Same problem in 2.6.5-1.309
Comment 2 John Burricelli 2004-04-10 11:19:56 EDT
The .315 kernel does the same thing.  Problem still exists when trying
to recompile the kernel.
Comment 3 Jim Cornette 2004-04-10 20:19:54 EDT
I had this problem when installing 2.6.5-1.308smp and the up kernel
also. There was no grub entry made and the intird was not created for
either kernel.
After I manually entered the kernel entries for the 2.6.5-1.308smp
kernel and ran mkintrd for both kernels, they loaded and seemed to
function alright.
This failure seems that it bails out after the reiserfs error (I am
not using a reiserfs on this particular installation.) I would expect
the reiserfs error would not stop the kernel from being installed and
from creating grub entries and an intird image. I would expect a
warning message regarding the error and letting the installer keep on
track.

Jim
Comment 4 Jim Cornette 2004-04-10 20:25:08 EDT
I see no references to using vmware when encountering this problem. I
am running vmware 4.5.1 on an xp operating system. Is this problem
common on a regular installation or just using vmware installations?
Comment 5 Svetlio Bajlekov 2004-04-11 19:21:15 EDT
I have not been able to compile any of Fedora's 2.6.5 kernels due to 
the same reason. Simple inspection shows that ReiserFS' journal.c 
references sleep_on(), while it is not included in sched.c.

I can, however, compile a "vanilla" 2.6.5 kernel (with the same 
configuration) due to a different sched.c provided there.
Comment 6 Jim Cornette 2004-04-11 21:31:25 EDT
I tried to mount my reiserfs volume on another computer that contains
a Fedora Core 1 installation. When I tried to mount the volume, as
root, I received the following error.

mount: fs type reiserfs not supported by kernel.

The kernel version is 2.6.5-1.315.

Comment 7 Arjan van de Ven 2004-04-16 04:57:56 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.