Bug 1204786 - [RFE] Allow users to create container without starting it
Summary: [RFE] Allow users to create container without starting it
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1204784 1204785 (view as bug list)
Depends On: 1221360 1221387
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 13:46 UTC by Bryan Kearney
Modified: 2017-02-23 20:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 13:59:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9393 0 None None None 2016-04-22 15:33:49 UTC

Description Bryan Kearney 2015-03-23 13:46:34 UTC
By the end of the wizard, there should be two buttons,  'create and start' or 'create'. A checkbox 'start on creation' or something similar would also work.

Comment 1 Bryan Kearney 2015-03-23 13:46:35 UTC
Created from redmine issue http://projects.theforeman.org/issues/9393

Comment 2 Bryan Kearney 2015-03-23 13:46:36 UTC
Upstream bug assigned to szadok@redhat.com

Comment 4 Brad Buckingham 2015-03-24 17:02:07 UTC
*** Bug 1204784 has been marked as a duplicate of this bug. ***

Comment 5 Brad Buckingham 2015-03-24 17:02:25 UTC
*** Bug 1204785 has been marked as a duplicate of this bug. ***

Comment 6 Shlomi Zadok 2015-04-14 14:43:45 UTC
Created https://github.com/theforeman/foreman-docker/pull/103 to fix this issue.

Comment 7 Bryan Kearney 2015-05-05 16:05:39 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9393 has been closed
-------------
Shlomi Zadok
Applied in changeset commit:foreman-docker|d5d9d39ee8a6a1c09c1c530b7d082c00cece0d38.

Comment 9 Tazim Kolhar 2015-05-21 12:13:47 UTC
here this bz is dependent on 
https://bugzilla.redhat.com/show_bug.cgi?id=1221387
hence once this is verified can proceed further
thanks

Comment 10 Tazim Kolhar 2015-05-22 07:58:02 UTC
this bz is dependent on https://bugzilla.redhat.com/show_bug.cgi?id=1224085
hence once this is verified can proceed further
thanks

Comment 11 Tazim Kolhar 2015-06-15 10:27:16 UTC
VERIFIED:
# rpm  -qa | grep foreman
ruby193-rubygem-foreman_discovery-2.0.0.15-1.el7sat.noarch
foreman-libvirt-1.7.2.27-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.14-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
dell-pe1955-02.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
foreman-compute-1.7.2.27-1.el7sat.noarch
foreman-gce-1.7.2.27-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.0-8.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
foreman-debug-1.7.2.27-1.el7sat.noarch
foreman-vmware-1.7.2.27-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.8-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.7-1.el7sat.noarch
foreman-proxy-1.7.2.5-1.el7sat.noarch
dell-pe1955-02.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
dell-pe1955-02.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.27-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-1.7.2.27-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
foreman-postgresql-1.7.2.27-1.el7sat.noarch

steps:
By the end of the wizard, there should be two buttons,  'create and start' or 'create'.

Comment 12 Bryan Kearney 2015-08-11 13:25:07 UTC
This bug is slated to be released with Satellite 6.1.

Comment 13 Bryan Kearney 2015-08-12 13:59:53 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.