Bug 1204861 - [gnome-shell] copy and paste with middle mouse button is not working in GNOME Terminal
Summary: [gnome-shell] copy and paste with middle mouse button is not working in GNOME...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 16:11 UTC by Joachim Frieben
Modified: 2015-11-07 11:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-20 15:07:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Frieben 2015-03-23 16:11:31 UTC
Description of problem:
As of current Fedora 22, copy and paste with the middle mouse button is not working in GNOME Terminal.

Version-Release number of selected component (if applicable):
gnome-shell-3.15.92-2.fc22

How reproducible:
Always

Steps to Reproduce:
1. Login to GNOME Wayland session.
2. Launch gnome-terminal.
3. Type some characters.
4. Select characters with mouse.
5. Press middle mouse button.

Actual results:
None.

Expected results:
Selected characters get pasted in gnome-terminal.

Additional info:
- This only happens in a GNOME Wayland session.
- Keyboard shortcut is working.
- Video chip is an AMD RV620.

Comment 1 Joachim Frieben 2015-04-20 14:54:13 UTC
Still broken in gnome-shell-3.16.1-1.fc22.

Comment 2 Joachim Frieben 2015-05-19 18:07:33 UTC
Still broken in gnome-shell-3.16.2-1.fc22.

Comment 3 Florian Müllner 2015-05-20 15:07:12 UTC
The selection buffer is an X-specific concept that does not exist in the wayland protocol.

Comment 4 Joachim Frieben 2015-05-21 10:14:30 UTC
(In reply to Florian Müllner from comment #3)
However, copy and paste with the middle mouse button works correctly for Fedora 21 during a wayland session. So, this looks like a regression to me.

Comment 5 Florian Müllner 2015-05-21 10:17:35 UTC
(In reply to Joachim Frieben from comment #4)
> (In reply to Florian Müllner from comment #3)
> However, copy and paste with the middle mouse button works correctly for
> Fedora 21 during a wayland session.

In Fedora 21, applications were still using the X backend by default, even in a wayland session.


Note You need to log in before you can comment on or make changes to this bug.