Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1204895 - RFE: virt-install: auto-add usb controller(s) for usbredir devices
Summary: RFE: virt-install: auto-add usb controller(s) for usbredir devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 7.2
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 17:16 UTC by David Jaša
Modified: 2015-11-19 05:24 UTC (History)
5 users (show)

Fixed In Version: virt-manager-1.2.0-1-el7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:24:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Description David Jaša 2015-03-23 17:16:55 UTC
Description of problem:
In domain XML, addition of usbredir devices requires specification of USB controllers where it is mandatory to specify exact PCI type of controller(s) and their addresses. Given that virt-install exists to abstract users away from these low-level details (e.g. by auto-creating pci and scsi controllers for respective devices), it should be able to authttps://cs.wikipedia.org/wiki/%C5%A0koda_21Tro-create USB controller(s) for usbredir devices. Maybe, there could be a specific suboption to --controller option for specification of USB2/3 controller version, but the low-level details should not be required, e.g.
virt-install [--controller usb,version=(2|3)] --redirdev 

In addition, "--redirdev usb,type=spicevmc" devices don't require any additional configuration opening options to further simplification for users:

virt-install [--controller usb,version=(2|3)] --redirdev usb,type=spicevmc,count=4


Version-Release number of selected component (if applicable):
virt-manager-1.1.0-12.el7.src.rpm


How reproducible:
always

Steps to Reproduce:
1. try to set up a VM with usb redirection using usb2 controller without need to specify PCI addresses or master ports

Comment 1 Giuseppe Scrivano 2015-03-23 17:31:12 UTC
do you mean something like:

virt-install --memory=2 --name=foo --nodisks  --pxe --controller usb2  --redirdev usb,type=spicevmc ?

Comment 2 David Jaša 2015-03-23 18:12:45 UTC
Thanks for the hint, the XML looks good. So could doc be updated to reflect that the feature already exists? The manual page only says:

"Controller also supports the special values usb2 and usb3"

but there is no further mention that they do what I requested.

Comment 3 Giuseppe Scrivano 2015-04-10 11:27:46 UTC
patch proposed upstream:

https://www.redhat.com/archives/virt-tools-list/2015-April/msg00079.html

Comment 4 Giuseppe Scrivano 2015-04-10 14:44:03 UTC
upstream commit:

commit 1f6faa33dc99c4b7990e505fc4ad9672baa39f09
Author: Giuseppe Scrivano <gscrivan@redhat.com>
Date:   Fri Apr 10 12:43:01 2015 +0200

    doc: make clearer what usb2 and usb3 means to --controller
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1204895
    
    Signed-off-by: Giuseppe Scrivano <gscrivan@redhat.com>

Comment 6 Xiaodai Wang 2015-06-23 09:16:22 UTC
I can reproduce this bug with package:
virt-install-1.1.0-13.el7.noarch.rpm  
virt-manager-1.1.0-13.el7.noarch.rpm  
virt-manager-common-1.1.0-13.el7.noarch.rpm

Steps:
1. Check the virt-install man page.
--controller=TYPE[,OPTS]
         Attach a controller device to the guest. TYPE is one of: ide, fdc, scsi, sata, virtio-serial, or usb.

         Controller also supports the special values usb2 and usb3.



Then try to verify with latest build:
virt-install-1.2.1-2.el7.noarch.rpm  
virt-manager-1.2.1-2.el7.noarch.rpm  
virt-manager-common-1.2.1-2.el7.noarch.rpm

Steps:
1. --controller OPTIONS
           Attach a controller device to the guest. TYPE is one of: ide, fdc, scsi, sata, virtio-serial, or usb.

           Controller also supports the special values usb2 and usb3 to specify which version of the USB controller should be used (version 2 or 3).


According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 8 errata-xmlrpc 2015-11-19 05:24:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.