Bug 120491 - MySQL daemon start script error timeout
MySQL daemon start script error timeout
Status: CLOSED DUPLICATE of bug 114982
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 08:00 EDT by mlbossi
Modified: 2013-07-02 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mlbossi 2004-04-09 08:00:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; it-IT; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
There is a problem in the mysqld daemon start script after changing
the root password in the "user" table of "mysql" database: the service
doesn't start correctly.


Version-Release number of selected component (if applicable):
3.23.58-10

How reproducible:
Always

Steps to Reproduce:
1. Consider a clean new installation of Fedora Core 1 whit MySQL. 
2. Change the root password in the "user" table of "mysql" database
(as indicated in the mysql user manual). 
3. Restart the mysqld service whit the command: service mysqld start

    

Actual Results:  The service doesn't start correctly: the mysqld
daemon run, but the console message is: 
 
 Timeout error occourred trying to start MySQL Daemon
 Starting mysqld      [FAILED]

Expected Results:  The service should start correctly:

  Starting mysql      [  OK  ]

Additional info:

After setting the root password in mysql DB "user" table, the
following command: 

    /usr/bin/mysqladmin ping 2

used in the sysV starting script (/etc/rc.d/init.d/mysqld) generate
this error when executing the daemon start:

  /usr/bin/mysqladmin: connect to server at 'localhost' failed
  error: 'Access denied for user: 'root@localhost' (Using passord: NO)'

It must be changed whit some like:

   /usr/bin/mysqladmin -u some_user ping 2

or just delete it from the script!
Comment 1 Tom Lane 2004-04-09 09:14:14 EDT
This bug is already fixed for FC2.

*** This bug has been marked as a duplicate of 114982 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.