Bug 1204923 - Parameters passed to Docker container are not being used when creating new container
Summary: Parameters passed to Docker container are not being used when creating new co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1292740
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 18:53 UTC by Og Maciel
Modified: 2019-09-25 20:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:14:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 10191 None None None 2016-04-22 15:38:49 UTC

Description Og Maciel 2015-03-23 18:53:51 UTC
Description of problem:

Assigning values for Memory, CPU Share etc while creating a Docker container does not seem to be working, as the information displayed (UI and using docker inspect command) does not show that the parameters passed were used.

Version-Release number of selected component (if applicable):

* Satellite-6.1.0-RHEL-7-20150320.1

How reproducible:


Steps to Reproduce:
1. Create a new Docker container using the web ui
2. Type 512m for Memory and 2 for CPU Share and finish the wizard
3.

Actual results:

The container created does not have the amount of memory and cpu share passed during the wizard

Expected results:


Additional info:

Comment 3 Bryan Kearney 2015-04-17 20:07:18 UTC
Created redmine issue http://projects.theforeman.org/issues/10191 from this bug

Comment 4 Bryan Kearney 2015-07-01 20:04:03 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10191 has been closed
-------------
Adam Ruzicka
Applied in changeset commit:foreman-docker|e88059db3a33445f654b199d803e4364662b7eaf.

Comment 5 Tazim Kolhar 2015-12-18 10:21:44 UTC
Currently, in upstream we are not able to create new container even after 
creating compute resource ..
thanks

Comment 13 errata-xmlrpc 2016-07-27 09:14:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.