Bug 12050 - Installer hangs/eats RAM in mke2fs
Installer hangs/eats RAM in mke2fs
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
sparc Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-10 11:28 EDT by rh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 12:43:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rh 2000-06-10 11:28:31 EDT
Hi,
  On my Sun/IPX I was trying to do a network install (by ftp) of RH6.2 and
have failed to get past creating a root filesystem.

It sat in mke2fs for more than an hour on a disc which is only 1GB in size
(reducing the partition to 500MB didn't help).

Looking at virtual console 5 you can see mke2fs running doing the 'writing
inode table' stage and giving numbers like 1800/30xxx - ticking round at
about 1 a second - so that would take more than 10 hours!

IPX's are slow but not that slow!

Looking at /proc/meminfo you can see that something is taking over 100MB of
swap and growing as mke2fs was running.

Dave
Comment 1 rh 2000-06-10 16:43:44 EDT
I now believe the problem is that Disk Druid incorrectly created the partition
tables so that the partition sizes were about 1000 times their real sizes -
which gave mke2fs a bit more work to do!

Ode for old reliable fdisk.
Comment 2 Michael Fulbright 2000-06-15 15:56:05 EDT
What size did you enter for the partition in disk druid? It accepts partition
sizes in units of Megabytes.
Comment 3 Michael Fulbright 2001-09-14 12:43:27 EDT
SPARC is no longer a supported platform.

Note You need to log in before you can comment on or make changes to this bug.