Bug 1205027 - named error during katello-install
Summary: named error during katello-install
Keywords:
Status: CLOSED DUPLICATE of bug 1205960
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-24 05:16 UTC by jnikolak
Modified: 2019-04-01 20:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-16 14:26:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jnikolak 2015-03-24 05:16:08 UTC
I'm installing Satellite 6 and run through the following error:

I completed yum install katello -y

Next I ran:

katello-installer --capsule-dns true --capsule-dns-interface eth0  --capsule-dns-zone jnikolak_sat6_rhel6a.gsslab.pek.redhat.com --capsule-dns-forwarders 10.72.17.5 --capsule-dns-reverse 169.208.66.10.in-addr.arpa --capsule-tftp true --capsule-tftp-servername $(hostname) --capsule-puppet true --capsule-puppetca true
 Could not start Service[named]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait named start' returned 2: Starting named: 
 /Stage[main]/Dns::Service/Service[named]/ensure: change from stopped to running failed: Could not start Service[named]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait named start' returned 2: Starting named: 
Installing             --- /etc/foreman-proxy/settings.d/dns.ymlg/Forema2014-12- [99%] [........................................................................................................................... /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: Failed to call refresh: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
 /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
 /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/returns: change from notrun to 0 failed: /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[jnikolak_sat6_rhel6a.gsslab.pek.redhat.com]: Could not evaluate: Could not load data from https://jnikolak_sat6_rhel6a.gsslab.pek.redhat.com
Installing             Done                                               [100%] [...............................................................................................................................]
  Something went wrong! Check the log for ERROR-level output


So i checked the error log
###################
katello installation error log
################
check install log
[ERROR 2015-03-24 03:41:10 main]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[jnikolak_sat6_rhel6a.gsslab.pek.redhat.com]: Could not evaluate: Could not load data from https://jnikolak_sat6_rhel6a.gsslab.pek.redhat.com
[ INFO 2015-03-24 03:41:10 main]  - is your server down?
[ INFO 2015-03-24 03:41:10 main]  - was rake apipie:cache run when using apipie cache? (typical production settings)



This didn't really help me much, so I tried to start named manually
###############
start named 
#################
service named start
Starting named: 
Error in named configuration:
zone localhost.localdomain/IN: loaded serial 0
zone localhost/IN: loaded serial 0
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
zone 0.in-addr.arpa/IN: loaded serial 0
dns_rdata_fromtext: /var/named/dynamic/db.169.208.66.10.in-addr.arpa:2: near 'jnikolak_sat6_rhel6a.gsslab.pek.redhat.com.': bad name (check-names)
dns_rdata_fromtext: /var/named/dynamic/db.169.208.66.10.in-addr.arpa:10: near 'jnikolak_sat6_rhel6a.gsslab.pek.redhat.com.': bad name (check-names)
zone 169.208.66.10.in-addr.arpa/IN: loading from master file /var/named/dynamic/db.169.208.66.10.in-addr.arpa failed: bad name (check-names)
zone 169.208.66.10.in-addr.arpa/IN: not loaded due to errors.
_default/169.208.66.10.in-addr.arpa/IN: bad name (check-names)
dns_rdata_fromtext: /var/named/dynamic/db.jnikolak_sat6_rhel6a.gsslab.pek.redhat.com:2: near 'jnikolak_sat6_rhel6a.gsslab.pek.redhat.com.': bad name (check-names)
dns_rdata_fromtext: /var/named/dynamic/db.jnikolak_sat6_rhel6a.gsslab.pek.redhat.com:10: near 'jnikolak_sat6_rhel6a.gsslab.pek.redhat.com.': bad name (check-names)
/var/named/dynamic/db.jnikolak_sat6_rhel6a.gsslab.pek.redhat.com:12: jnikolak_sat6_rhel6a.gsslab.pek.redhat.com: bad owner name (check-names)
zone jnikolak_sat6_rhel6a.gsslab.pek.redhat.com/IN: loading from master file /var/named/dynamic/db.jnikolak_sat6_rhel6a.gsslab.pek.redhat.com failed: bad name (check-names)
zone jnikolak_sat6_rhel6a.gsslab.pek.redhat.com/IN: not loaded due to errors.
_default/jnikolak_sat6_rhel6a.gsslab.pek.redhat.com/IN: bad name (check-names)
                                                           [FAILED]

######
edit /etc/named.conf
######################

I resolved the issue by editing: /etc/named.conf
I added 3 options.
check-names master ignore;
check-names slave ignore; 
check-names response ignore;

Then saved the file --->
------------------------------
include "/etc/rndc.key";

controls  {
	inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { "rndc-key"; };
};

options  {
	include "/etc/named/options.conf";

check-names master ignore;
check-names slave ignore; 
check-names response ignore;
};
---------------------------
Sevice named restart now works successfully

I think this could be a bug as it was quite unexpected and not mentioned anywhere in installation to use this workaround.

If required the server is on redhat network.....

Comment 1 jnikolak 2015-03-24 05:17:33 UTC
More information:

rpm -qa katello
katello-1.5.0-30.el6sat.noarch


This was found on rhev peking, and not on customer box.

Comment 2 RHEL Program Management 2015-03-24 05:33:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 jnikolak 2015-03-24 06:22:31 UTC
I then realised that the installation doesn't complete, as the /etc/named.conf is overwritten.

I then applied the change to 
/usr/share/katello-installer/modules/dns/templates/named.conf.erb


Then the named problem doesnt occur

Comment 5 Ivan Necas 2015-06-10 07:34:45 UTC
The problem here is with underscores 'jnikolak_sat6_rhel6a.gsslab.pek.redhat.com', which is not valid fqdn: turning off the name checking is just workaround on one level, but can cause other issues.

What we can do is validating the dns-zone for being a valid fqdn


Note You need to log in before you can comment on or make changes to this bug.