Bug 1205044 - Satellite 6 katello-installer could not start [foreman-tasks]
Summary: Satellite 6 katello-installer could not start [foreman-tasks]
Keywords:
Status: CLOSED DUPLICATE of bug 1205960
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-24 06:40 UTC by jnikolak
Modified: 2017-02-23 20:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 15:07:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug (354.04 KB, application/x-xz)
2015-03-25 08:14 UTC, jnikolak
no flags Details

Description jnikolak 2015-03-24 06:40:40 UTC
I was install Satellite 6, however I made an error with my installation configuration.


I believe that upon running katello-installer there should be a script to run 
katello-services stop

Without this command I was able to replicate the issue with:

katello-installer --capsule-dns true --capsule-dns-interface eth0  --capsule-dns-zone jnikolak_sat6_rhel6a.gsslab.pek.redhat.com --capsule-dns-forwarders 10.72.17.5 --capsule-dns-reverse 169.208.66.10.in-addr.arpa --capsule-tftp true --capsule-tftp-servername jnikolak_sat6_rhel6a.gsslab.pek.redhat.com --capsule-puppet true --capsule-puppetca true --capsule-dhcp true --capsule-dhcp-interface eth0 --capsule-dhcp-gateway 10.66.208.254

###############
output
###############
Could not start Service[foreman-tasks]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait foreman-tasks start' returned 10: Starting foreman-tasks: Some processes of foreman-tasks is already running. Some not. Please stop foreman-tasks first.[FAILED]
 /Stage[main]/Foreman::Plugin::Tasks/Service[foreman-tasks]/ensure: change from stopped to running failed: Could not start Service[foreman-tasks]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait foreman-tasks start' returned 10: Starting foreman-tasks: Some processes of foreman-tasks is already running. Some not. Please stop foreman-tasks first.[FAILED]
 /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
 /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/returns: change from notrun to 0 failed: /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[jnikolak_sat6_rhel6a.gsslab.pek.redhat.com]: Could not evaluate: Could not load data from https://jnikolak_sat6_rhel6a.gsslab.pek.redhat.com
Installing             Done                                               [100%] [...............................................................................................................................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log

############# Log file
[DEBUG 2015-03-24 06:20:29 main]  Finishing transaction 70171129751220
[DEBUG 2015-03-24 06:20:29 main]  Received report to process from jnikolak_sat6_rhel6a.gsslab.pek.redhat.com
[DEBUG 2015-03-24 06:20:29 main]  Processing report from jnikolak_sat6_rhel6a.gsslab.pek.redhat.com with processor Puppet::Reports::Store
[ INFO 2015-03-24 06:20:33 main] Puppet has finished, bye!
[ INFO 2015-03-24 06:20:33 main] Executing hooks in group post
[DEBUG 2015-03-24 06:20:33 main] Hook /usr/share/katello-installer/hooks/post/10-post_install.rb returned nil
[ INFO 2015-03-24 06:20:33 main] All hooks in group post finished
[DEBUG 2015-03-24 06:20:33 main] Exit with status code: 6 (signal was 6)
[ERROR 2015-03-24 06:20:33 main] Repeating errors encountered during run:
[ERROR 2015-03-24 06:20:33 main]  Could not start Service[foreman-tasks]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait foreman-tasks start' returned 10: Starting foreman-tasks: Some processes of foreman-tasks is already running. Some not. Please stop foreman-tasks first.[FAILED]
[ERROR 2015-03-24 06:20:33 main]  /Stage[main]/Foreman::Plugin::Tasks/Service[foreman-tasks]/ensure: change from stopped to running failed: Could not start Service[foreman-tasks]: Execution of '/usr/share/katello-installer/modules/service_wait/bin/service-wait foreman-tasks start' returned 10: Starting foreman-tasks: Some processes of foreman-tasks is already running. Some not. Please stop foreman-tasks first.[FAILED]
[ERROR 2015-03-24 06:20:33 main]  /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
[ERROR 2015-03-24 06:20:33 main]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/returns: change from notrun to 0 failed: /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
[ERROR 2015-03-24 06:20:33 main]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[jnikolak_sat6_rhel6a.gsslab.pek.redhat.com]: Could not evaluate: Could not load data from https://jnikolak_sat6_rhel6a.gsslab.pek.redhat.com
[DEBUG 2015-03-24 06:20:33 main] Cleaning /etc/katello-installer/d20150
##########################

Comment 1 RHEL Program Management 2015-03-24 06:53:24 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Eric Helms 2015-03-24 17:44:34 UTC
Is the output in the comment from the first run or a subsequent run? Do you have a foreman-debug?

Comment 4 jnikolak 2015-03-25 08:14:05 UTC
Created attachment 1006151 [details]
foreman-debug

The output is from a second or third run.
I've attached the foreman-debug

Comment 5 Eric Helms 2015-04-21 15:07:22 UTC
There are 2 things I noticed in the logs:

1) This error /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Validation failed: Value must be a valid URI which I believe is generated if the hostname is not a valid hostname
2) Based on the above, and looking through the logs I see underscores in the hostname which is an invalid format. 


There is an existing bug open to check for this case and prevent the installer from continuing that I am going to mark this bug as a duplicate of.

*** This bug has been marked as a duplicate of bug 1205960 ***


Note You need to log in before you can comment on or make changes to this bug.