Bug 1205047 - Remove Activation Key dialog box UI behaves improperly with bigger name of activation key.
Summary: Remove Activation Key dialog box UI behaves improperly with bigger name of ac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Uncategorized
Version: 6.1.0
Hardware: Unspecified
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-24 07:05 UTC by Jitendra Yejare
Modified: 2019-09-25 21:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:49:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of Dialog box and Window with Bigger name of activation key (308.05 KB, application/x-gzip)
2015-03-24 07:05 UTC, Jitendra Yejare
no flags Details
Name wrapping (185.26 KB, image/png)
2015-11-10 19:45 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11831 None None None 2016-04-22 16:36:16 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2015-03-24 07:05:44 UTC
Created attachment 1005668 [details]
Screenshot of Dialog box and Window with Bigger name of activation key

Description of problem:
The activation key name goes out of Remove activation key dialog box when the activation key name will be bigger in length(I tried with 170 characters).

Version-Release number of selected component (if applicable):
Satellite 6 Snap 7 Compose 3

How reproducible:
Always

Steps to Reproduce:
1. Create an activation key with bigger length of activation key.
2. After crating an activation key, Click on Remove button.
3. Observe the activation key name in Remove dialog box.

Actual results:
The activation key name goes out of Remove activation key dialog box when the activation key name will be bigger in length.

Expected results:
The activation key name should be displayed properly in Remove dialog box irrespective to size of activation key name. 

Additional info:
The same observed that the activation key name is going out of window in This Activation Key -> Details tab under label "This activation key may be used during system registration. For example". There is no scroll bar displayed to view the name fully or copy. Expecting to display the scroll bar to view the full name.

Comment 2 Walden Raines 2015-09-15 15:33:08 UTC
Created redmine issue http://projects.theforeman.org/issues/11831 from this bug

Comment 3 Walden Raines 2015-09-15 16:03:17 UTC
PR: https://github.com/Katello/bastion/pull/78

Comment 4 Bryan Kearney 2015-09-15 16:03:51 UTC
Upstream bug component is Content Management

Comment 5 Bryan Kearney 2015-09-16 18:03:36 UTC
Upstream bug component is Uncategorized

Comment 6 Bryan Kearney 2015-09-16 18:03:38 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11831 has been closed
-------------
Walden Raines
Applied in changeset commit:bastion|c7a06ac7a2523ed8141f4b6fabe9d35b89a946ed.

Comment 7 jcallaha 2015-11-10 19:45:03 UTC
Verified in Upstream. Name now wraps within the element. See attached screenshot.

  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.11.0-develop
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.8.4

Comment 8 jcallaha 2015-11-10 19:45:34 UTC
Created attachment 1092403 [details]
Name wrapping

Comment 11 errata-xmlrpc 2016-07-27 08:49:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.