Bug 120505 - ATAPIIX DMA timeouts when HD Fails
Summary: ATAPIIX DMA timeouts when HD Fails
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 16:24 UTC by Andre Dumouchelle
Modified: 2013-07-03 02:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 17:37:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Dumouchelle 2004-04-09 16:24:22 UTC
Description of problem:

ICH5-R system w/ 2 SATA HDs.  If power/data cable is pulled from 
drive (simulating failure) system locks w/ DMA timeouts.  System 
never recovers

Version-Release number of selected component (if applicable):


How reproducible:

Easy

Steps to Reproduce:
1. Load EL3 gold w/ ATAPIIX module on SATA drives
2. Pull cable from SATA data drive
3. View timeouts/system lock
  
Actual results:


Expected results:


Additional info:

Comment 1 Matt Domsch 2004-05-26 15:15:08 UTC
Jeff, any feeling on this?

Comment 2 Jeff Garzik 2005-02-18 07:22:05 UTC
Does this still occur?  I believe this was fixed a while back, when an
error in the error handling code was fixed.


Comment 3 John Feeney 2007-07-12 17:37:31 UTC
With RHEL3 now in maintenance mode, where only critical customer issues
can be fixed, this bugzilla has been closed as "works for me" due to a 
comment made by the engineer, its severity level and a lack of recent 
activity. 


Note You need to log in before you can comment on or make changes to this bug.