Bug 1205057 - tools/glusterfind: Provide API for testing status of session creation
Summary: tools/glusterfind: Provide API for testing status of session creation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades
TreeView+ depends on / blocked
 
Reported: 2015-03-24 07:34 UTC by Milind Changire
Modified: 2015-05-14 17:35 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Milind Changire 2015-03-24 07:34:58 UTC
Description of problem:
"glusterfind pre" emits a list of changed files since the last checkpoint.
"glusterfind pre --full" emits a list of all files.
The decision to run either of the above commands depends on the creation of a
session status file $GLUSTERD_WORKDIR/SESSION/VOLUME/status
Typically the test to check for the status file should be available as an API
rather then exposing the file path directly or expecting administrators to test
the file presence explicitly.


Version-Release number of selected component (if applicable):
master

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Something like "glusterfind --ischeckpointed <SESSION> <VOLUME>"

Additional info:

Comment 1 Anand Avati 2015-04-07 11:40:16 UTC
REVIEW: http://review.gluster.org/10154 (tools/glusterfind: Check existence of Session) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Aravinda VK 2015-04-07 11:43:30 UTC
Use glusterfind list --session <SESSION> --volume <VOLUME> to validate the session. Session is valid if return value is zero.

Comment 3 Anand Avati 2015-04-09 07:16:43 UTC
REVIEW: http://review.gluster.org/10154 (tools/glusterfind: Check existence of Session) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Anand Avati 2015-04-09 09:53:45 UTC
COMMIT: http://review.gluster.org/10154 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 3ed7d6de25cba5e24351fd4771e84c7182436916
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Apr 7 16:47:15 2015 +0530

    tools/glusterfind: Check existence of Session
    
    Use glusterfind list command to check a session is valid or not
    
        glusterfind list --session <SESSION> --volume <VOLUME>
    
    Session exists if return code($?) is zero else invalid session
    
    Change-Id: I37faa09e4e1bf2f10725dd8e5b0cc36a36a3cad4
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    BUG: 1205057
    Reviewed-on: http://review.gluster.org/10154
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 5 Niels de Vos 2015-05-14 17:26:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:28:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.