Bug 120520 - sparc64 needs support for pcidomains
Summary: sparc64 needs support for pcidomains
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 19:40 UTC by Tom "spot" Callaway
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 18:43:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix pcidomains for sparc64 (1.16 KB, patch)
2004-04-09 19:41 UTC, Tom "spot" Callaway
no flags Details | Diff

Description Tom "spot" Callaway 2004-04-09 19:40:42 UTC
In 2.6, sparc64 now has pcidomains. This breaks x.org, but thankfully,
the fine folks over at Gentoo SPARC have a patch to fix the issue,
without breaking compatibility with 2.4.

Please apply the attached patch, and submit it upstream, since I'm not
entirely sure about how to do this.

Comment 1 Tom "spot" Callaway 2004-04-09 19:41:53 UTC
Created attachment 99280 [details]
Patch to fix pcidomains for sparc64

Comment 2 John Dennis 2004-04-12 17:27:00 UTC
I'll take this one since I've been doing a fair amount of other PCI
work and have delt with the domain issue previously.

Comment 3 John Dennis 2004-04-15 18:43:27 UTC
rolled patch into existing xorg-use-linux-pci-only.patch because they
are closely related, that patch still needs to be turned on in the
spec file once the branch issue for FC2 is resolved.

Comment 4 Donnie Berkholz 2004-04-19 18:14:50 UTC
If you guys want to send this upstream, please do. I've been swamped
lately and haven't had spare time for anything.

Comment 5 Donnie Berkholz 2004-07-06 09:53:37 UTC
Upstreamed:
http://freedesktop.org/bugzilla/show_bug.cgi?id=827


Note You need to log in before you can comment on or make changes to this bug.