Bug 120522 - (PATCH CPUSPEED) cpuspeed -p option does not work
Summary: (PATCH CPUSPEED) cpuspeed -p option does not work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 19:52 UTC by Nickolai Zeldovich
Modified: 2015-01-04 22:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 09:49:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix cpuspeed's -p option (358 bytes, patch)
2004-04-19 19:06 UTC, Nickolai Zeldovich
no flags Details | Diff

Description Nickolai Zeldovich 2004-04-09 19:52:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
[root@nestea kolya]# /usr/sbin/cpuspeed -h 2>&1 | grep -5 .-p
 
        -i <interval>
            Sets the interval between idle percentage tests and possible
            speed changes in 1/10 second increments (default is 20).
 
        -p <fast up> <threshold>
            Sets the CPU idle percentage thresholds.  <fast up> is the
idle
            percentage below which the CPU will be set to the highest
possible
            speed.  <threshold> is the idle percentage above which the CPU
            speed will be decreased and below which the CPU speed will be
            increased (defaults are 10 and 25).
[root@nestea kolya]# /usr/sbin/cpuspeed -p 10 25
Error: The -p option must be followed by 2 integers
 
[root@nestea kolya]#



Version-Release number of selected component (if applicable):
kernel-utils-2.4-9.1.127

How reproducible:
Always

Comment 1 Nickolai Zeldovich 2004-04-19 19:06:14 UTC
Created attachment 99537 [details]
Patch to fix cpuspeed's -p option

Comment 2 Nickolai Zeldovich 2004-04-19 19:07:28 UTC
Obvious patch to fix this bug is attached.  Submitted upstream about a
week ago without any response, so maybe you guys want to just apply it
locally to the Fedora RPMs.

Comment 3 David Baron 2004-09-12 02:15:46 UTC
It looks like this has been applied in kernel-utils-2.4-9.1.131 .


Note You need to log in before you can comment on or make changes to this bug.