Bug 1205221 - On removing a content-host, logs raises error type message instead of info that host is deleted
Summary: On removing a content-host, logs raises error type message instead of info th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-24 13:13 UTC by Sachin Ghai
Modified: 2019-09-25 21:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:49:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
production.log (6.65 KB, text/plain)
2015-03-24 13:14 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2015-03-24 13:13:11 UTC
Description of problem:
I removed a content-host from webUI and message thrown in production.log is:

--
[ERROR 2015-03-24 08:21:54 pulp_rest  #29219] RestClient.delete "https://cisco-e160dp-01.rhts.eng.bos.redhat.com/pulp/api/v2/consumers/d0c722ef-7883-4a21-bffb-8a210a5c9051/", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"OAuth oauth_consumer_key=\"katello\", oauth_nonce=\"zC79YaiqZ6agqHJAoc6pqrY0DTK1NHNjYDypJqME0\", oauth_signature=\"BPBPJqiklWJJyIMr8RxjuU4FKPA%3D\", oauth_signature_method=\"HMAC-SHA1\", oauth_timestamp=\"1427199714\", oauth_version=\"1.0\"", "accept"=>"application/json", "content_type"=>"application/json", "pulp-user"=>"admin-ede27445"
 | \n# => 200 OK | application/json 4 bytes
 | 
---



Version-Release number of selected component (if applicable):
sat6.1 beta snap7 compose3
Satellite-6.1.0-RHEL-7-20150320.1

How reproducible:
always

Steps to Reproduce:
1. register a content host
2. delete content-host from UI
3.

Actual results:
--
[ERROR 2015-03-24 08:21:54 pulp_rest  #29219] RestClient.delete "https://cisco-e160dp-01.rhts.eng.bos.redhat.com/pulp/api/v2/consumers/d0c722ef-7883-4a21-bffb-8a210a5c9051/", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"OAuth oauth_consumer_key=\"katello\", oauth_nonce=\"zC79YaiqZ6agqHJAoc6pqrY0DTK1NHNjYDypJqME0\", oauth_signature=\"BPBPJqiklWJJyIMr8RxjuU4FKPA%3D\", oauth_signature_method=\"HMAC-SHA1\", oauth_timestamp=\"1427199714\", oauth_version=\"1.0\"", "accept"=>"application/json", "content_type"=>"application/json", "pulp-user"=>"admin-ede27445"
 | \n# => 200 OK | application/json 4 bytes
 | 
---


Expected results:
shouldn't be an error.. it should be a info as Rest apis saying host deleted and giving 200 ok status

Additional info:

Comment 1 Sachin Ghai 2015-03-24 13:14:43 UTC
Created attachment 1005844 [details]
production.log

Comment 3 Brad Buckingham 2015-08-26 18:54:39 UTC
Testing this on a Satellite 6.1.1 GA install, I do not see the 'ERROR'.  

Version:
foreman-1.7.2.34-1.el7sat.noarch
katello-2.2.0.15-1.el7sat.noarch
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch

Log:

[DEBUG 2015-08-26 14:52:18 pulp_rest  #2042] RestClient.delete "https://sat611.ga/pulp/api/v2/consumers/61c2d594-51ef-439a-a9e2-55bff8ca48b3/", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"OAuth oauth_consumer_key=\"katello\", oauth_nonce=\"oZfz6DiO1wOknBDSs4Atx8rGwMp9GcDWvdr88tnJs8\", oauth_signature=\"Q8%2FY7%2BfOKhqssGroK6DNlujn3wM%3D\", oauth_signature_method=\"HMAC-SHA1\", oauth_timestamp=\"1440615137\", oauth_version=\"1.0\"", "accept"=>"application/json", "content_type"=>"application/json", "pulp-user"=>"admin-4c0b88a1"
 | \nRestClient.delete "https://localhost:8443/candlepin/consumers/61c2d594-51ef-439a-a9e2-55bff8ca48b3", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"OAuth oauth_consumer_key=\"katello\", oauth_nonce=\"ZB0TfgCNIi94K0Q5O4Khz2412io0OfEXtt08aghuFjk\", oauth_signature=\"ftyGjKkX4fSxfQvvVJP0dN1G5jw%3D\", oauth_signature_method=\"HMAC-SHA1\", oauth_timestamp=\"1440615137\", oauth_version=\"1.0\"", "cp-user"=>"admin"
 | \n# => 200 OK | application/json 4 bytes

Moving to ON_QA for verification.

Comment 4 jcallaha 2015-10-29 19:01:41 UTC
Verified in upstream. Successfully completed the content host removal without any errors.

 HOSTNAME: rhsm-qe-1.rhq.lab.eng.bos.redhat.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.11.0-develop
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.8.3
  DENIALS: 0


2015-10-29 14:47:34 [app] [I] Processing by Katello::Api::V2::SystemsController#destroy as JSON
2015-10-29 14:47:34 [app] [I]   Parameters: {"api_version"=>"v2", "id"=>"60b23819-bde1-422f-b7e0-6fe22cd67c6f"}
2015-10-29 14:47:35 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.5.0/app/views/katello/api/v2/common/destroy.json.rabl within katello/api/v2/layouts/resource (0.8ms)
2015-10-29 14:47:35 [app] [I] Completed 204 No Content in 852ms (Views: 2.2ms | ActiveRecord: 0.0ms)

Comment 7 errata-xmlrpc 2016-07-27 08:49:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.