Bug 1205281 - Tuskar installation incomplete - DB not set up properly
Summary: Tuskar installation incomplete - DB not set up properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: Director
Assignee: Jay Dobies
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-24 15:29 UTC by Brad P. Crochet
Modified: 2015-08-05 13:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, migration to a puppet deployment meant that the boot-stack tripleo-image-element was no longer creating the initial Tuskar database. Consequently, after successful installation of the undercloud, the Tuskar service was not correctly configured. This release ensures that Tuskar is properly installed and configured for the undercloud. As a result, after successful installation of the undercloud, you can interact with the Tuskar service.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Brad P. Crochet 2015-03-24 15:29:21 UTC
Description of problem:
After an undercloud installation, the tuskar api service is not set up properly. The connection string is not set in the [database] section of /etc/tuskar/tuskar.conf. It is blank.

This causes a 500 error when called from the tuskarclient. tuskar-dbsync also throws an error (this is returned by the api to the client as well)

CRITICAL tuskar [-] ArgumentError: Could not parse rfc1738 URL from string ''

Version-Release number of selected component (if applicable):
instack-undercloud-2.0.0-dev1493.g17b20f4.el7.centos.noarch
openstack-tripleo-puppet-elements-0.0.1-f2531bf.el7.centos.noarch
openstack-tripleo-image-elements-0.9.2.37-g3e3c022.el7.centos.noarch
openstack-tuskar-2013.2-dev32.ga3ed626.el7.centos.noarch



How reproducible:
100%

Steps to Reproduce:
1. Follow sphinx documents to install the undercloud. 
2. Try to do any operation on the tuskar api.

Actual results:
Database not configured for tuskar

Expected results:
Database configured for tuskar

Comment 3 Brad P. Crochet 2015-03-26 21:42:55 UTC
I have done some investigation here. Things started breaking here: https://github.com/rdo-management/instack-undercloud/commit/6f75c8dc3c37d489763b7310a7b57d00e1e70da2

Problem is that the info for tuskar was removed from elements/undercloud-stack-config/config.json.template.

So, I am working on implementing the necessary puppet to bring this in properly.

Comment 4 James Slagle 2015-03-30 12:22:14 UTC
i put up a patch to correct this:
https://review.gerrithub.io/#/c/228655/

but that will conflict with the puppet work you're doing, so just let me know if you want me to hold off on merging it

Comment 5 Brad P. Crochet 2015-03-30 23:25:46 UTC
I've now submitted a few patches to enable this:

puppet-tuskar - https://review.openstack.org/#/c/169072/
tripleo-puppet-elements - https://review.openstack.org/#/c/169070/
tuskar-packaging - https://review.gerrithub.io/#/c/228840/
instack-undercloud - https://review.gerrithub.io/#/c/228909/

Comment 6 Brad P. Crochet 2015-04-01 16:52:35 UTC
We should go for slagle's patch for now. There is more work to be done on the puppet to have feature parity with the tripleo tuskar element.

Comment 7 Jay Dobies 2015-05-26 17:58:38 UTC
Moving to MODIFIED; I just tested it on a new instack install and it works correctly.

Comment 11 Udi 2015-06-09 10:10:01 UTC
Verified in puddle 2015-06-02 and openstack-tuskar-2013.2.0-dev2.el7.centos.noarch

Comment 14 errata-xmlrpc 2015-08-05 13:50:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.