Bug 120535 - No Chance to Confirm/Review/Modify Pointing Device Selection
No Chance to Confirm/Review/Modify Pointing Device Selection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 23:14 EDT by Joel Rittvo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-11 14:37:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Rittvo 2004-04-09 23:14:08 EDT
Description of problem:

During a new install, either standard or using "noprobe", the 
installer finds a generic 3-button ps2 mouse, an unprobed monitor, 
and an nVidia video card.  The finding on the mouse is incorrect.  It 
is actually a Synaptics laptop touchpad.  I am never given a screen 
where I can confirm or modify the mouse type the installer 
has "probed".  I do get a screen to select the monitor.  I get no 
screen as well for the video card, but it isn't causing any problems 
with the generic nVidia it selects on its own.

The problem with the mouse selection is that I don't get the taps and 
scrolls that should be part of the touchpad setup.  The bigger 
problem is that the installer should, I think, be allowing me to 
confirm or modify the hardware it sets up for the monitor, card and 
pointing device, and it is only allowing a selection for the 
monitor.  I do get language choices and keyboard choices, but it goes 
from those to monitor to partitioning, with no chance for video or 
pointer modifications.

How reproducible:

Every time.

Steps to Reproduce:
1.Start install from CD-1
2.Wait for opportunity to verify/modify pointing device selection.
3.
  
Actual results:

Lets me select/modify the screen type, but not the video card or the 
pointing device.  Goes from language choice to screen choice to 
partitioning settings.


Expected results:

I should be able to change the incorrect automatic selection on the 
pointing device to the actual device by going through a lost of 
manufacturers and models, as in the screen selection.

Additional info:

Computer is a Dell Inspiron 5150 Laptop
Comment 1 Jeremy Katz 2004-04-11 14:37:13 EDT
This is intentional since the new input layer in 2.6 makes it so that
things should "just work" for the general case.  Anything special like
mouse taps, etc can be configurable post-install (and preferably on a
per-user basis)

Note You need to log in before you can comment on or make changes to this bug.