Bug 120536 - Arts should default to using ESD
Summary: Arts should default to using ESD
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: arts   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-10 03:53 UTC by Michel Alexandre Salim
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 20:20:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michel Alexandre Salim 2004-04-10 03:53:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
Since Fedora ships with GNOME as the default desktop, and using ALSA
drivers I could not simply 'esddsp artsd' or 'artsdsp esd' it would be
nice if arts could be preconfigured to use esd for its output.

A KDE power user would probably know which global settings file one
could do this in, but the per-user file is
~/.kde/share/config/kcmartsrc, and the relevant setting is 'AudioIO=esd'

With this set I now have my GNOME apps (and KDE games) happily coexisting.


Version-Release number of selected component (if applicable):
arts-1.2.1-2

How reproducible:
Always

Steps to Reproduce:
1. Enable ESD
2. Run KDE sound-outputting app (say KReversi) from within GNOME

    

Actual Results:  a KDE warning is outputted in a message box that the
sound server could not bind to the sound card and it would set up a
null audio card instead

Expected Results:  Sound Just Work (TM)

Additional info:

Comment 1 Ngo Than 2004-04-14 20:20:32 UTC
with kcontrol you can easily select your default audio device.

the default audio divice will be ALSA.


Note You need to log in before you can comment on or make changes to this bug.