Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1205512 - Run validation in editor document list is disabled when it should not be.
Run validation in editor document list is disabled when it should not be.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.7
Unspecified Unspecified
unspecified Severity low
: ---
: 3.7
Assigned To: Patrick Huang
Zanata-QA Mailling List
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-25 01:49 EDT by David Mason
Modified: 2015-07-21 22:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3352)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-21 22:19:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2015-03-25 01:49:18 EDT
Description of problem:
Attempting to run validations for the documents when no validation is selected causes the 'Run validations' button to be disabled permanently (until browser window refresh). The button does not become available again even if validations are checked in the list.

Presumably the button was intended to be disabled immediately when no validations are selected, and re-enabled when one or more validations are selected.


Version-Release number of selected component (if applicable):


How reproducible:
Easy, always




Steps to Reproduce:
1. Sign in and open the editor on any project-version for any locale
2. Navigate to the documents tab
3. Open the validation options panel
4. Un-check every validation
5. Click 'Run validation'


Actual results:
'Run validation' button becomes disabled and cannot be re-enabled.


Expected results:
'Run validation' button is disabled as soon as the last remaining validation is unchecked, and is enabled as soon as any validation is checked.
Comment 1 Patrick Huang 2015-04-22 02:33:51 EDT
The button is disabled when user click on it and the validation is running in the background(on server). It's supposed to re-enable itself once the validation result comes back. But because there is no validation to run in this case (all unchecked), there is no result and button remains disabled. 

In summary, the button is enable or not does not depend on whether we have validation rules checked. It depends on whether validation is running in the background.

I will make it so that if there is no rules checked, it won't disable. It will just has no effect when you click on it. This differ from the expected result. If you insist it should work as stated in description, please comment here.
Comment 2 David Mason 2015-04-22 21:45:41 EDT
(In reply to Patrick Huang from comment #1)
> In summary, the button is enable or not does not depend on whether we have
> validation rules checked. It depends on whether validation is running in the
> background.

This is surprising behaviour if the user cannot see why the button is disabled. There should be some text on or next to the button when it is disabled that tells the user the reason (i.e. "Validation is already running").


> I will make it so that if there is no rules checked, it won't disable. It
> will just has no effect when you click on it. This differ from the expected
> result. If you insist it should work as stated in description, please
> comment here.

That change would solve this problem. It would be more usable if the button is disabled when no validation is selected, with a message next to or on the button saying "no validations selected".

Is there a use-case for running no validations? If I run a validation and see a warning icon next to a document, then I run no validations, I would expect the warning to go away since all the documents should pass the validations that I have selected (which is none). I think we should make it work that way, or disable the button.
Comment 3 Patrick Huang 2015-04-27 20:57:00 EDT
https://github.com/zanata/zanata-server/pull/783
Comment 4 Damian Jansen 2015-04-28 01:46:23 EDT
Verified (master) at 774be1165637f0aa506167f575ead8d6c4786f3c

Note You need to log in before you can comment on or make changes to this bug.