Bug 1205534 - gnome-initial-setup crashes upon selecting language
Summary: gnome-initial-setup crashes upon selecting language
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rui Matos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-25 06:59 UTC by Jens Petersen
Modified: 2016-07-19 19:06 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 19:06:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Jens Petersen 2015-03-25 06:59:10 UTC
Description of problem:
gnome-initial-setup seems to have problems with the initial language screen.
Selecting (most/any?) language seems to make it crash after a short pause.

Version-Release number of selected component (if applicable):
gnome-initial-setup-3.15.91.1-1.fc22

How reproducible:
100%

Steps to Reproduce:
1. install Fedora 22 Workstation with/out user
2. reboot (login if user created)
3. gnome-intial-setup appears
4. select a language

Actual results:
4. gnome-initial-setup crashes

Expected results:
4. no crash! :)

Additional info:
will try to add link/info on the crash

Comment 1 Jens Petersen 2015-03-25 07:09:37 UTC
Also with gnome-initial-setup-3.15.92-1.fc22

Comment 2 Jens Petersen 2015-03-25 07:11:34 UTC
Will try later with https://admin.fedoraproject.org/updates/gnome-initial-setup-3.16.0-1.fc22

Comment 3 Jens Petersen 2015-03-25 07:14:56 UTC
If one doesn't create a user (and root) in anaconda there seems no way
to start an gnome session.

Comment 4 Matthias Clasen 2015-03-25 20:23:11 UTC
how about a stack trace ? do you have one ?

Comment 5 Rui Matos 2015-03-26 12:22:38 UTC
Tried to reproduce after installing F22 beta TC4 (which includes g-i-s 3.15.91.1) and couldn't reproduce. Tried installing g-i-s 3.15.92 and restarting gdm, also didn't crash after selecting a language.

So, I'm puzzled and would need either more specific steps to reproduce or at least a stack trace.

BTW, note that g-i-s 3.16.0 doesn't have any code changes compared to 3.15.92.

Comment 6 Jaroslav Reznik 2015-03-30 14:06:02 UTC
Might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1206404? There's journal attached.

Comment 7 Matthias Clasen 2015-03-30 16:30:17 UTC
(In reply to Jaroslav Reznik from comment #6)
> Might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1206404?
> There's journal attached.

Seems unlikely. This is a crash - the bug you mention shows no sign of a crash

Comment 8 Adam Williamson 2015-03-30 16:36:19 UTC
Discussed at 2015-03-30 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-30/f22-blocker-review.2015-03-30-16.04.log.txt . We are not entirely clear on the current status of this issue; we will try to reproduce and investigate further before making a determination.

Comment 9 Adam Williamson 2015-04-06 16:48:13 UTC
Discussed at 2015-04-06 blocker review meeting: https://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-06/f22-blocker-review.2015-04-06-16.00.log.txt . Since we suck, no-one managed to find time to try and reproduce this (though the fact we've had no dupes from abrt is suggestive). Once again we'll delay the determination while we try to reproduce.

Comment 10 Mike Ruckman 2015-04-06 17:18:56 UTC
-1, I can't reproduce this locally.

Comment 11 Stephen Gallagher 2015-04-06 17:21:53 UTC
-1, I also attempted to reproduce this on Beta TC8 and could not.

Comment 12 Adam Williamson 2015-04-06 17:43:56 UTC
We re-discussed this bug later in the blocker review meeting with the test results from #c10 and #c11, and agreed it is rejected as a blocker as we cannot reproduce it. Please re-propose if you can provide a reproducer with Beta TC8+.

Comment 13 Fedora End Of Life 2016-07-19 19:06:33 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.