Bug 1205604 - Mark the lockout ldap_access_order as deprecated
Summary: Mark the lockout ldap_access_order as deprecated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 7.3
Assignee: SSSD Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-25 10:11 UTC by Kaushik Banerjee
Modified: 2020-05-02 17:59 UTC (History)
9 users (show)

Fixed In Version: sssd-1.14.0-7.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:11:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 3651 None None None 2020-05-02 17:59:31 UTC
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Kaushik Banerjee 2015-03-25 10:11:42 UTC
Description of problem:
Currently ldap_access_order can be set to either ppolicy or lockout, both of which are used for the same purpose.

Version-Release number of selected component (if applicable):
sssd-1.12.4-11.el6

How reproducible:
Always

Steps to Reproduce:
1. In the following domain section of sssd, ldap_access_order can be lockout of ppolicy
[domain/LDAP]
id_provider = ldap
ldap_uri = ldaps://<ldapserver>
ldap_search_base = dc=example,dc=com
ldap_tls_cacert = /etc/openldap/certs/cert.pem
access_provider = ldap
ldap_access_order = ppolicy
#ldap_access_order = lockout
ldap_pwdlockout_dn = cn=pwdconfig,ou=ppolicy,dc=example,dc=com

2.
3.

Actual results:


Expected results:
Only ppolicy works since it is stricter than lockout

Additional info:

Comment 1 Pavel Reichl 2015-03-25 10:29:05 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2610

Comment 5 Jakub Hrozek 2016-07-08 13:14:30 UTC
This was fixed in 108a49f0e816d95cf75a1e964f63b397e53c8b56

Comment 7 shridhar 2016-09-12 10:03:15 UTC

Verified with sssd-1.14.0-36.el7.x86_64 # man sssd_ldap <snip>
<snip>
    ldap_access_order (string)

        lockout: use account locking. If set, this option denies access in case that ldap attribute 'pwdAccountLockedTime' is present and has value of '000001010000Z'. Please see the option ldap_pwdlockout_dn. Please note that 'access_provider = ldap' must be set for this feature to work.

            Please note that this option is superseded by the “ppolicy” option and might be removed in a future release.

</snip>

Comment 9 errata-xmlrpc 2016-11-04 07:11:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.