Bug 1205727 - [RFE][HC] - Host activate should restart glusterd
Summary: [RFE][HC] - Host activate should restart glusterd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-3.6.2
: 3.6.2.2
Assignee: bugs@ovirt.org
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1205724
Blocks: Generic_Hyper_Converged_Host Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-03-25 14:30 UTC by Sahina Bose
Modified: 2016-03-11 07:21 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: When a host is activated, the glusterd services are restarted on host to enable host to rejoin cluster
Clone Of:
Environment:
Last Closed: 2016-03-11 07:21:16 UTC
oVirt Team: Gluster
rule-engine: ovirt-3.6.z+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

Description Sahina Bose 2015-03-25 14:30:58 UTC
Description of problem:
If gluster service is enabled on a host, activating the host should restart glusterd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
NA

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 10:57:40 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Ramesh N 2015-12-09 05:49:49 UTC
This already take care as part of the bz#1205724.

Comment 3 Allon Mureinik 2016-01-10 09:32:06 UTC
Moving to ON_QA, as per bug 1205724.

Comment 4 Red Hat Bugzilla Rules Engine 2016-01-10 09:32:11 UTC
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

Comment 5 Red Hat Bugzilla Rules Engine 2016-01-10 09:32:11 UTC
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.

Comment 6 SATHEESARAN 2016-02-26 02:37:04 UTC
Tested with RHEV 3.6.3.3 and RHGS 3.1.2 RC , by adding RHGS 3.1.2 RC Node to 3.5 compatible cluster

1. Moving the host to maintenance ( & stopping gluster services ) and activating it, starts all the gluster services
2. Moving the host to maintenance ( & not stopping gluster services ) and activating it, restarts only glusterd service


Note You need to log in before you can comment on or make changes to this bug.