Bug 120575 - kernel-2.6.5-1.315 freezes w/ "bad pmd" messages
kernel-2.6.5-1.315 freezes w/ "bad pmd" messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-10 23:06 EDT by Tom London
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 08:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2004-04-10 23:06:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Kernel randomly freezes.  Did NOT occur with kernel-2.6.5-1.309.

/var/log/messages show:

Apr 10 18:56:33 fedora mdmpd: mdmpd failed
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c4000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c8000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0cc000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c4000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c8000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0cc000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c4000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c8000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0cc000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c4000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c8000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0cc000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c4000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c8000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0cc000e3.
Apr 10 18:56:33 fedora init: open(/dev/pts/0): No such file or directory
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c4000e3.
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0c8000e3.
Apr 10 18:56:33 fedora init: open(/dev/pts/0): No such file or directory
Apr 10 18:56:33 fedora last message repeated 5 times
Apr 10 18:56:33 fedora kernel: mm/memory.c:102: bad pmd 0cc000e3.


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.315

How reproducible:
Sometimes

Steps to Reproduce:
1. Install 315 kernel
2. Boot.  Sometimes freezes before going multi-user.
3. Wait....
    

Additional info:
Comment 1 Arjan van de Ven 2004-04-12 08:06:13 EDT
ok found it; fixed in build 318 from
http://people.redhat.com/arjanv/2.6/
which is rsyncing to the server right now.
Comment 2 Tom London 2004-04-12 12:43:23 EDT
Quick response!  Thanks.

Since my system was freezing left and right, I "yum"-ed build 319 from
http://people.redhat.com/arjanv/2.6/.

Seems to be working......

thanks again.
Comment 3 Mathieu Chouquet-Stringer 2004-04-12 13:41:39 EDT
I was having some problems starting X so I upgraded my kernel to
version 319. Just got an oops, here it is:
Apr 12 13:45:13 shookaylt kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000000
Apr 12 13:45:13 shookaylt kernel:  printing eip:
Apr 12 13:45:13 shookaylt kernel: 0217869f
Apr 12 13:45:13 shookaylt kernel: *pde = 00000000
Apr 12 13:45:13 shookaylt kernel: Oops: 0000 [#1]
Apr 12 13:45:13 shookaylt kernel: CPU:    0
Apr 12 13:45:13 shookaylt kernel: EIP:    0060:[<0217869f>]    Not tainted
Apr 12 13:45:13 shookaylt kernel: EFLAGS: 00013297   (2.6.5-1.319) 
Apr 12 13:45:13 shookaylt kernel: EIP is at d_find_alias+0xa8/0x207
Apr 12 13:45:13 shookaylt kernel: eax: 00000000   ebx: 00000000   ecx:
14ae2e88   edx: 17004454
Apr 12 13:45:13 shookaylt kernel: esi: 12a87a80   edi: 00000000   ebp:
21ebf400   esp: 14ae2d9c
Apr 12 13:45:13 shookaylt kernel: ds: 007b   es: 007b   ss: 0068
Apr 12 13:45:13 shookaylt kernel: Process xkbcomp (pid: 1946,
threadinfo=14ae2000 task=188cf360)
Apr 12 13:45:13 shookaylt kernel: Stack: 00000000 17004444 00100000
021b82e0 1a4f0484 0000029a 00100000 021c4a15 
Apr 12 13:45:13 shookaylt kernel:        00100000 14ae2e00 00000000
00000000 00003202 123a911c 00000000 fffffffe 
Apr 12 13:45:13 shookaylt kernel:        021b945a 00100000 14ae2e00
00000000 0000029a 00000200 14ae2000 00000000 
Apr 12 13:45:13 shookaylt kernel: Call Trace:
Apr 12 13:45:13 shookaylt kernel:  [<021b82e0>] avc_audit+0x365/0xa5a
Apr 12 13:45:13 shookaylt kernel:  [<021c4a15>]
security_compute_av+0x8d/0x96
Apr 12 13:45:13 shookaylt kernel:  [<021b945a>]
avc_has_perm_noaudit+0x1a2/0x488
Apr 12 13:45:13 shookaylt kernel:  [<02140215>]
buffered_rmqueue+0x1e9/0x20c
Apr 12 13:45:13 shookaylt kernel:  [<021b977f>] avc_has_perm+0x3f/0x49
Apr 12 13:45:13 shookaylt kernel:  [<021bad68>] inode_has_perm+0x57/0x5f
Apr 12 13:45:13 shookaylt kernel:  [<021bc67c>]
selinux_inode_permission+0x7a/0x7e
Apr 12 13:45:13 shookaylt kernel:  [<0216dd23>] permission+0x41/0x46
Apr 12 13:45:13 shookaylt kernel:  [<0216e537>] link_path_walk+0x112/0xcd8
Apr 12 13:45:13 shookaylt kernel:  [<0216f350>] path_lookup+0xf8/0x128
Apr 12 13:45:13 shookaylt kernel:  [<0216f9b4>] open_namei+0x93/0x409
Apr 12 13:45:13 shookaylt kernel:  [<0215d7e2>] filp_open+0x23/0x3c
Apr 12 13:45:13 shookaylt kernel:  [<0215ddc4>] sys_open+0x31/0x7d
Apr 12 13:45:13 shookaylt kernel: 
Apr 12 13:45:13 shookaylt kernel: Code: 8b 00 0f 18 00 90 8d 73 c4 f6
46 04 10 0f 85 a8 00 00 00 f6 
Apr 12 13:45:13 shookaylt kernel:  lib/dec_and_lock.c:32:
spin_lock(fs/dcache.c:02334914) already locked by fs/dcache.c/293
Comment 4 Arjan van de Ven 2004-04-12 13:48:49 EDT
that's one odd oops; can you please open a new bug for it so that we
can keep it separate from the pmd issue? Thank you.

Note You need to log in before you can comment on or make changes to this bug.