Bug 1205785 - dht linkfile are created with different owner:group than that source(data) file in few cases
Summary: dht linkfile are created with different owner:group than that source(data) fi...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard: triaged
Keywords:
Depends On: 884597 1168392
Blocks: 895528 902200
TreeView+ depends on / blocked
 
Reported: 2015-03-25 15:36 UTC by Nithya Balachandran
Modified: 2015-05-14 17:46 UTC (History)
13 users (show)

(edit)
Clone Of: 1168392
(edit)
Last Closed: 2015-05-14 17:29:24 UTC


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-03-25 15:45:54 UTC
REVIEW: http://review.gluster.org/9998 (Cluster/DHT Mismatching gfid values in dht_local_t) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 2 Nithya Balachandran 2015-03-25 16:13:39 UTC
The issue is seen because dht_linkfile_create() uses the gfid in local->gfid  and dht_linkfile_attr_heal() uses the value in local->stbuf.gfid. In a situation where duplicate files with different gfids are present on the bricks (because of another bug), these values do not match, causing the failure as the linkfile is created with one gfid but the attr_heal is done with the other gfid.

Comment 3 Anand Avati 2015-03-25 16:14:42 UTC
REVIEW: http://review.gluster.org/9998 (Cluster/DHT Mismatching gfid values in dht_local_t) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 4 Anand Avati 2015-03-26 06:54:24 UTC
REVIEW: http://review.gluster.org/9998 (Cluster/DHT Mismatching gfid values in dht_local_t) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 5 Anand Avati 2015-03-27 05:08:04 UTC
REVIEW: http://review.gluster.org/9998 (Cluster/DHT Mismatching gfid values in dht_local_t) posted (#4) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 6 Anand Avati 2015-04-07 11:10:32 UTC
REVIEW: http://review.gluster.org/9998 (Cluster/DHT Mismatching gfid values in dht_local_t) posted (#5) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 7 Anand Avati 2015-04-08 19:47:24 UTC
COMMIT: http://review.gluster.org/9998 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit a7f1d08b8f0bdf8d251590d6f7e4acc46f2486b4
Author: Nithya Balachandran <nbalacha@redhat.com>
Date:   Wed Mar 25 21:07:36 2015 +0530

    Cluster/DHT Mismatching gfid values in dht_local_t
    
    If multiple files with the same name but different gfids
    exist on different subvolumes, dht_lookup_everywhere_cbk()
    copies the gfid from the last received response into
    local->gfid but does not update the local->stbuf structure.
    dht_linkfile_create() uses the value in local->gfid, but
    dht_linkfile_attr_heal() uses the one in local->stbuf, causing
    a mismatch and failure while trying to heal the linkfile attrs.
    
    Change-Id: I80d152be95b42d736c5d9182b955f42e374b82a5
    BUG: 1205785
    Signed-off-by: Nithya Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/9998
    Reviewed-by: Susant Palai <spalai@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Tested-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 8 Niels de Vos 2015-05-14 17:29:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:38:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:46:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.