Bug 1205825 - instack-undercloud: instack-install-undercloud exits with error Cannot reassign variable ssl_interface at /etc/puppet/modules/rabbitmq/manifests/config.pp:35
Summary: instack-undercloud: instack-install-undercloud exits with error Cannot reass...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: Emilien Macchi
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-25 17:05 UTC by Alexander Chuzhoy
Modified: 2016-04-18 06:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A duplicate line in the RabbitMQ configuration caused the Undercloud installation to fail. This fix removes the duplicate line and the Undercloud installation is now successful.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-03-25 17:05:26 UTC
instack-undercloud:  instack-install-undercloud exists with error Cannot reassign variable ssl_interface at /etc/puppet/modules/rabbitmq/manifests/config.pp:35 


Environment:
instack-0.0.6.4-g57c723a.el7.centos.noarch
instack-undercloud-2.0.0-dev1508.el7.centos.noarch

Steps to reproduce:
Run instack-install-undercloud


Result:

[2015/03/25 12:52:32 PM] [INFO] running ifdown on interface: p2p1                                                                                                                                                    
[2015/03/25 12:52:32 PM] [INFO] running ifdown on interface: p2p1                                                                                                                                                    
[2015/03/25 12:52:32 PM] [INFO] running ifdown on bridge: br-ctlplane                                                                                                                                                
[2015/03/25 12:52:32 PM] [INFO] Writing config /etc/sysconfig/network-scripts/route-br-ctlplane                                                                                                                      
[2015/03/25 12:52:32 PM] [INFO] Writing config /etc/sysconfig/network-scripts/ifcfg-br-ctlplane                                                                                                                      
[2015/03/25 12:52:32 PM] [INFO] Writing config /etc/sysconfig/network-scripts/route-p2p1                                                                                                                             
[2015/03/25 12:52:32 PM] [INFO] Writing config /etc/sysconfig/network-scripts/ifcfg-p2p1                                                                                                                             
[2015/03/25 12:52:32 PM] [INFO] running ifup on bridge: br-ctlplane                                                                                                                                                  
[2015/03/25 12:52:36 PM] [INFO] running ifup on interface: p2p1                                                                                                                                                      
[2015/03/25 12:52:37 PM] [INFO] running ifup on interface: p2p1                                                                                                                                                      
[2015/03/25 12:52:38 PM] [INFO] running ifup on interface: p2p1                                                                                                                                                      
dib-run-parts Wed Mar 25 12:52:39 EDT 2015 20-os-net-config completed
dib-run-parts Wed Mar 25 12:52:39 EDT 2015 Running /usr/libexec/os-refresh-config/configure.d/40-hiera-datafiles
[2015/03/25 12:52:39 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json
dib-run-parts Wed Mar 25 12:52:39 EDT 2015 40-hiera-datafiles completed
dib-run-parts Wed Mar 25 12:52:39 EDT 2015 Running /usr/libexec/os-refresh-config/configure.d/50-puppet-stack-config
+ set -o pipefail
+ set +e
+ puppet apply --detailed-exitcodes /etc/puppet/manifests/puppet-stack-config.pp
Warning: You cannot collect without storeconfigs being set on line 235 in file /etc/puppet/manifests/puppet-stack-config.pp
Warning: You cannot collect without storeconfigs being set on line 239 in file /etc/puppet/manifests/puppet-stack-config.pp
Warning: You cannot collect without storeconfigs being set on line 243 in file /etc/puppet/manifests/puppet-stack-config.pp
Error: Cannot reassign variable ssl_interface at /etc/puppet/modules/rabbitmq/manifests/config.pp:35 on node rhos-compute-node-13.osqe.lab.eng.bos.redhat.com
Error: Cannot reassign variable ssl_interface at /etc/puppet/modules/rabbitmq/manifests/config.pp:35 on node rhos-compute-node-13.osqe.lab.eng.bos.redhat.com
+ rc=1
+ set -e
+ echo 'puppet apply exited with exit code 1'
puppet apply exited with exit code 1
+ '[' 1 '!=' 2 -a 1 '!=' 0 ']'
+ exit 1
[2015-03-25 12:52:44,231] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]

[2015-03-25 12:52:44,231] (os-refresh-config) [ERROR] Aborting...


Expected result:
instack-install-undercloud should complete successfully.

Comment 4 Alexander Chuzhoy 2015-03-25 17:50:57 UTC
Wrokaround:
remove the duplucate line (35) from  /etc/puppet/modules/rabbitmq/manifests/config.pp and re-run the instack-install-undercloud

Comment 7 Alexander Chuzhoy 2015-06-01 21:03:03 UTC
Verified:
Envorinment: 
instack-0.0.6-5.el7ost.noarch
instack-undercloud-2.1.0-3.el7ost.noarch

The reported issue doesn't reproduce.

Comment 11 errata-xmlrpc 2015-08-05 13:51:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.