Bug 1205864 - [abrt] dnssec-trigger: dnssec-trigger-script:278:_commit:KeyError: 'c.f.ip6.arpa'
Summary: [abrt] dnssec-trigger: dnssec-trigger-script:278:_commit:KeyError: 'c.f.ip6.a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnssec-trigger
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Hozza 🤓
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5047f400f5a61da7f288314ac9c...
: 1206825 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-25 19:39 UTC by George Nikandrov
Modified: 2015-04-21 18:49 UTC (History)
8 users (show)

Fixed In Version: dnssec-trigger-0.12-20.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-18 09:32:21 UTC


Attachments (Terms of Use)
File: backtrace (874 bytes, text/plain)
2015-03-25 19:39 UTC, George Nikandrov
no flags Details
File: environ (95 bytes, text/plain)
2015-03-25 19:39 UTC, George Nikandrov
no flags Details

Description George Nikandrov 2015-03-25 19:39:50 UTC
Description of problem:
Stock 

Version-Release number of selected component:
dnssec-trigger-0.12-19.fc22

Additional info:
reporter:       libreport-2.5.0
cmdline:        /usr/bin/python3 /usr/libexec/dnssec-trigger-script --update
executable:     /usr/libexec/dnssec-trigger-script
kernel:         4.0.0-0.rc4.git0.1.fc22.x86_64
runlevel:       unknown
type:           Python3
uid:            0

Truncated backtrace:
dnssec-trigger-script:278:_commit:KeyError: 'c.f.ip6.arpa'

Traceback (most recent call last):
  File "/usr/libexec/dnssec-trigger-script", line 634, in <module>
    Application(sys.argv).run()
  File "/usr/libexec/dnssec-trigger-script", line 414, in run
    self.method()
  File "/usr/libexec/dnssec-trigger-script", line 563, in run_update
    self.run_update_connection_zones()
  File "/usr/libexec/dnssec-trigger-script", line 627, in run_update_connection_zones
    unbound_zones.add(zone, global_forwarders, secure=False)
  File "/usr/libexec/dnssec-trigger-script", line 250, in add
    self._commit(zone, set(servers), secure)
  File "/usr/libexec/dnssec-trigger-script", line 278, in _commit
    del self.cache[name]
KeyError: 'c.f.ip6.arpa'

Local variables in innermost frame:
self: <UnboundZoneConfig(data={})>
name: 'c.f.ip6.arpa'
secure: False
servers: set()

Comment 1 George Nikandrov 2015-03-25 19:39:53 UTC
Created attachment 1006435 [details]
File: backtrace

Comment 2 George Nikandrov 2015-03-25 19:39:55 UTC
Created attachment 1006436 [details]
File: environ

Comment 3 Tomáš Hozza 🤓 2015-03-30 07:44:52 UTC
*** Bug 1206825 has been marked as a duplicate of this bug. ***

Comment 4 Tomáš Hozza 🤓 2015-03-31 09:36:59 UTC
Thank you for this report.

This is a bug in the dnssec-trigger Python script. In case there is no connection available, meaning there are no global forwarders, then the script
tries to configure the RFC 1918 reverse zones and fails.

I'll prepare a patch.

Comment 5 Tomáš Hozza 🤓 2015-04-02 18:32:01 UTC
Patch sent to the upstream. I'll push an update once they merge it.

Comment 6 Fedora Update System 2015-04-08 16:32:00 UTC
dnssec-trigger-0.12-20.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnssec-trigger-0.12-20.fc21

Comment 7 Fedora Update System 2015-04-08 16:33:49 UTC
dnssec-trigger-0.12-20.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-3864/dnssec-trigger-0.12-20.fc22

Comment 8 Fedora Update System 2015-04-09 09:09:46 UTC
Package dnssec-trigger-0.12-20.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnssec-trigger-0.12-20.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5821/dnssec-trigger-0.12-20.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-04-18 09:32:21 UTC
dnssec-trigger-0.12-20.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-04-21 18:49:13 UTC
dnssec-trigger-0.12-20.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.