Bug 120589 - Undefined symbol sleep_on in reiserfs.ko
Undefined symbol sleep_on in reiserfs.ko
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 11:56 EDT by Phil Schaffner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 10:05:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Schaffner 2004-04-11 11:56:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
reiserfs module fails to load due to undefined symbol "sleep_on" in
kernels 2.6.5-1.309 and 2.6.5-1.315

Tried a kernel rebuild from kernel-source-2.6.5-1.315.

Relevant errors seem to be:

  CC [M]  fs/reiserfs/journal.o
fs/reiserfs/journal.c: In function `queue_log_writer':
fs/reiserfs/journal.c:2466: warning: `sleep_on' is deprecated
(declared at include/linux/wait.h:228)
...
WARNING: /lib/modules/2.6.5-1.315custom/kernel/fs/reiserfs/reiserfs.ko
needs unknown symbol sleep_on
WARNING: /lib/modules/2.6.5-1.315custom/kernel/fs/reiserfs/reiserfs.ko
needs unknown symbol sleep_on

(Also, a bit worrying that a "make oldconfig" using
configs/kernel-2.6.5-i686.config prompted for new items.)

Noted that sleep_on was only used by reiserfs whereas there were a lot
of warnings along the lines of:

fs/autofs/waitq.c:166: warning: `interruptible_sleep_on' is deprecated
(declared at include/linux/wait.h:231)

Despite not being in the same league with "real" kernel hackers, I
changed "sleep_on" to "interruptible_sleep_on" on line 2466 of
fs/reiserfs/journal.c, did

  make && make modules_install && make install

noted apparent success, and boldly rebooted.

Unsurprisingly, still get the "mm/memory.c:102: bad pmd 0c4000e3"
errors described in fedora-test "kernel bug in .315" thread, but
reiserfs now seems to be working again.


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.315, kernel-source-2.6.5-1.315

How reproducible:
Always

Steps to Reproduce:
1. Boot with kernel-2.6.5-1.315 (or 309)
2. Have reiserfs partition in /etc/fstab
3.
    

Actual Results:  The reiserfs module fails to load due to undefinde
symbol.

Expected Results:  Module should load and reiserfs partitions[s] mount.

Additional info:

available on request...
Comment 1 Jim Cornette 2004-04-11 21:37:20 EDT
I am experiencing the missing reiserfs module also. I tried to mount
the volume and got the below error.
mount: fs type reiserfs not supported by kernel.

At least the error is not locking up the computer or similar. The
volume is simply not accessable. 


Comment 2 Phil Schaffner 2004-04-12 16:07:33 EDT
Add latest arjanv kernel-2.6.5-1.319 to the list of those with this
problem.
Comment 3 Jim Cornette 2004-04-13 19:14:15 EDT
Strange thing that I encountered when running a file system check
because of an unclean shutdown. The reisrefs journal was replayed, but
when the system was fully booted, the module for reiserfs would not load.
How was the journal replayed on a filesystem check and not loadable
when the system should be more capable?
Comment 4 Phil Schaffner 2004-04-14 13:07:31 EDT
FC2T2 kernel-2.6.5-1.322 still exhibits this problem.  Same hack on
fs/reiserfs/journal.c is still working for me as a bandaid.
Comment 5 Arjan van de Ven 2004-04-15 10:05:24 EDT
326 has this fixed properly; will hit rawhide tomorrow and
http://people.redhat.com/arjanv/2.6/ in a few minutes

Note You need to log in before you can comment on or make changes to this bug.