Bug 120590 - Kudzu is not consistent on recognization of "U.S. Robotics 56K Voice INT PnP" dial-up modem
Kudzu is not consistent on recognization of "U.S. Robotics 56K Voice INT PnP"...
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2004-04-11 12:07 EDT by Ali Servet Donmez
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-23 17:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ali Servet Donmez 2004-04-11 12:07:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I'm not good at Linux, but i will try to understand my problem on 

I have an "U.S. Robotics 56K Voice INT PnP" dial-up modem. When i've 
first tried to use RH9, Kudzu didn't recognize my modem as a part of 
my PC. That was a problem for me. I've used RH9 as a Linux experience 
for my self for couple of days, then one day something happened to 
me: Kudzu recognized my modem and installed it. After that day i had 
connection to internet which is a great think for a Linux user. I've 
shutdown my PC at night and went to sleep. On the next day when i 
booted my PC, Kudzu told me that "My hardware was removed", BUT IT 
WASN'T! Kudzu asked my to remove it or not, i've choose to "not 
remove it", and continued to use my modem normally. After that day, 
each time i boot my PC Kudzu tells me that hardware is removed, i 
select to "not remove" it, and continue to use it very well.

As an extra information; "MS Windows 98SE/2000/XP" has no problem at 
all with this software, and using it about 5-6 years.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot PC normally
2. See the Kudzu screen which tells that: "Hardware is removed"
3. Then select to "not remove it"

(I'm not sure about the selection titles my the meanings are the 
same... Example: Maybe Kudzu doesn't say "not remove" but the meaning 
is the same)

Additional info:
Comment 1 Bill Nottingham 2004-04-13 00:13:09 EDT
What does 'kudzu -p -b isapnp' say?
Comment 2 Ali Servet Donmez 2004-04-15 16:02:07 EDT
Here's your answer:

[root@localhost root]#kudzu -p -b isapnp
class: UNSPEC
detached: 0
driver: unknown
desc: "U.S. Robotics 56K Voice INT:Unknown"
deviceId: USR3090
pdeviceId: USR3090
native: 0
active: 1
cardnum: 0
logdev: 0
io: 0x2f8
irq: 3

An additional if information:
Today is my lucky day! RH9 recognized my modem as a "Generic Modem" 
now everything works fine except my each boot. On my each boot kudzu 
says that this hardware is removed, but IT IS NOT!!! I click 
on "ignore" (not remove it), then i use my modem with no problems.

Waiting for comments and solutions.
Comment 3 geoffroy de bettignies 2004-04-16 07:51:24 EDT
Very interesting.
I installed Fedora core 1 a week ago on my PC(abit NF7-S, nforce2 
chipset see: 
during the install the integrated ethernet adaptor wasn't recognized.
connected to the PC were a USB printer and a USB scanner, and an 
external modem on com1 (olitec speed'com v92 ready) that is supposed 
not to require any driver under linux.
They were all recognized during install.
First reboot : kudzu says that the modem isn't connected and prompts 
for removal of config.
I tried to update kudzu, it changes nothing.
I've installed the nvidia drivers for the chipset, and kudzu now sees 
the ethernet, but for the modem it changes nothing.
The modem can be used, but at each reboot kudzu doesn't see it.
I've seen so far bug reports 112699, 120590 and 111404 with more or 
less the same issue and seen the problem on different forums.
Comment 4 Bill Nottingham 2005-09-23 17:02:27 EDT
Closing bugs on older, no longer supported releases. Apologies for any lack of

Please attempt to reproduce this bug on a currently supported release, such as
Fedora Core 4. If it persists, please open a new bug in bugzilla.

Note You need to log in before you can comment on or make changes to this bug.