Bug 120591 - (NET E100)during installation, getNetConfig ignores DHCP Offer msg
(NET E100)during installation, getNetConfig ignores DHCP Offer msg
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 12:59 EDT by Tim Taiwanese Liim
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 18:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Taiwanese Liim 2004-04-11 12:59:51 EDT
Component Text:
boot.iso/{getNetConfig or pump or e100}

Description of problem:
getNetConfig fails to respond to "DHCP Offer" msg when
using boot.iso CD with Installation Method FTP/HTTP.  

Version-Release number of selected component (if applicable):
CD boot image from
ftp://ftp.linux.ncsu.edu/pub/fedora/linux/core/test/1.91/i386/os/images/boot.iso

How reproducible:
Always fail on Toshiba Portege 7000CT notebook w/ 64MB RAM.
Never  fail on IBM T23 w/ 256MB RAM.

Steps to Reproduce:
1. Boot from CD with said boot.iso, with no kernel argument.
2. Choose "FTP" as Installation Method.
   Window 3 says
      * devices[0] is Intel Corp.|82557/8/9 [Ethernet Pro 100] -
           eth0 using e100 (loaded)
      ...
      * going to do getNetConfig
3. At Configure TCP/IP, choose DHCP.
   Window 3 says
      * waiting for link...
      * 0 seconds.
      * pump told us: No DHCP reply received
  
Actual results:
   The DHCP Offer msg seemed to be discarded, either by pump or
   lower layer of network stack.

Expected results:
    Should use the info from DHCP Offer msg.

Additional info:
    If I choose to use static IP, it seems that incoming network
    packets are discarded too, so it could be lower layer of 
    network stack that discards the packets.

    The same installation method (FTP) worked with Fedora Core 1 
    boot.iso on the same set of hardware.

    From ethereal, 6 tries of DHCP Discover was sent at
       t = 0, 4, 11, 24, 30, 30 sec.
    The DHCP server responds with DHCP Offer with 0.01 sec each 
    time.
Comment 1 Phil Knirsch 2004-04-13 09:41:55 EDT
Reassigning to anaconda, net-tools don't have a lot to do with the
installation per se.

Read ya, Phil
Comment 2 Jeremy Katz 2004-04-13 15:21:07 EDT
Driver bug
Comment 3 Alan Cox 2004-05-03 08:15:56 EDT
What is in the kernel log (should be console-4 - alt-shift-f4), does
it report timeouts. Does it work if you specify acpi=off in the boot
messages ?
Comment 4 Tim Taiwanese Liim 2004-10-19 23:49:45 EDT
The "acpi=off" kernel argument works well.  If no one objects, I
will close this bug report on 10/27/04 since workaround is
available.



Detail of further attemps:
CD boot image from
  
ftp://ftp.linux.ncsu.edu/pub/fedora/linux/core/2/i386/iso/FC2-i386-disc1.iso

Attempt #1 (bad case): boot with NO "acpi=off" 
    1. Boot from CD with said FC2-i386-disc1.iso., with 
            linux askmethod text

    2. Choose "FTP" as Installation Method.
       Window 3 says
          * modules to insert mii e100
          * loaded e100 from /modules/modules.cgz
          * inserted /tmp/e100.ko
       Window 4 says
        <4>ACPI: No IRQ known for interrupt pin B of device
0000:00:0b.1 - using IRQ 255
        <6>e100: Intel(R) PRO/100 Network Driver, 3.0.17
        <6>e100: Copyright(c) 1999-2004 Intel Corporation
        <4>ACPI: No IRQ known for interrupt pin A of device 0000:00:06.0
        <7>divert: allocating divert_blk for eth0
        <6>e100: eth0: e100_probe: addr 0xdefff000, irq 11, MAC addr xx
    3. At Configure TCP/IP, choose DHCP.
       Window 3 says
          * going to do getNetConfig
          * waiting for link...
          * 0 seconds.
          * pump told us: No DHCP reply received
       Window 4 says (earlier logs scrolled out of view)
            <6> e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
            <135>Oct 20 19:59:07 loader: CLASSID: sending anaconda
            <135>Oct 20 19:59:07 loader: PUMP: sending discover
            <135>Oct 20 19:59:07 loader: breq: opcode: 1
            <135>Oct 20 19:59:07 loader: breq: hw:1
            <135>Oct 20 19:59:07 loader: breq: hwlength: 6
            <135>Oct 20 19:59:07 loader: breq: hopcount: 0
            <135>Oct 20 19:59:07 loader: breq: xid: 0xdfc6f69a
            <135>Oct 20 19:59:07 loader: breq: secs: 0
            <135>Oct 20 19:59:07 loader: breq: flags: 0x0000
            <135>Oct 20 19:59:07 loader: breq: ciaddr: 0.0.0.0
            <135>Oct 20 19:59:07 loader: breq: yiaddr: 0.0.0.0
            <135>Oct 20 19:59:07 loader: breq: server_ip: 0.0.0.0
            <135>Oct 20 19:59:07 loader: breq: boot_gw_ip: 0.0.0.0
            <135>Oct 20 19:59:07 loader: breq: hwaddr:
            <135>Oct 20 19:59:07 loader: breq: servername:
            <135>Oct 20 19:59:07 loader: breq: bootfile:
            <135>Oct 20 19:59:07 loader: breq: vendor: 0x63 0x53 0x82 0x63
            <135>Oct 20 19:59:07 loader: breq: vendor:  53   1 0x01
            <135>Oct 20 19:59:07 loader: breq: vendor:  60   9 0x61
0x6e 0x61 0x6
            <135>Oct 20 19:59:07 loader: breq: vendor: ++++++ 0x6f
0x6e 0x64 0x61
            <135>Oct 20 19:59:07 loader: breq: vendor: ++++++ 0x00
            <135>Oct 20 19:59:07 loader: breq: vendor: 0xff

Attempt #2 (good case): boot with "acpi=off" 
    1. Boot from CD with said FC2-i386-disc1.iso., with 
            linux askmethod text acpi=off

    2. Choose "FTP" as Installation Method.
       Window 3 says (same as Attempt #1)
          * modules to insert mii e100
          * loaded e100 from /modules/modules.cgz
          * inserted /tmp/e100.ko
       Window 4 says (ACPI msgs replaced by PCI msgs)
        <6>PCI: Found IRQ 11 for device 0000:00:0b.1       <== different
        <6>e100: Intel(R) PRO/100 Network Driver, 3.0.17
        <6>e100: Copyright(c) 1999-2004 Intel Corporation
        <6>PCI: Found IRQ 11 for device 0000:00:06.0       <== different
        <6>PCI: Sharing IRQ 11 with 0000:00:04.0           <== different
        <6>PCI: Sharing IRQ 11 with 0000:00:09.0           <== different
        <7>divert: allocating divert_blk for eth0
        <6>e100: eth0: e100_probe: addr 0xdefff000, irq 11, MAC addr xx
    3. At Configure TCP/IP, choose DHCP.
        eth0 works well.


Note You need to log in before you can comment on or make changes to this bug.