Bug 120601 - setools-devel removed but not Obsolete'ed
setools-devel removed but not Obsolete'ed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 17:13 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 15:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-04-11 17:13:52 EDT
Description of problem:

setools-1.2.1-6 removes setools-devel from being distributed but it
does not Obsolete the package so up2date does not know to delete the
package.
Comment 1 Daniel Walsh 2004-04-12 13:48:09 EDT
Added obsolete
setools-1.2.1-7
Comment 2 Gene Czarcinski 2004-04-13 15:36:23 EDT
OK, I am closing this since it appears to be fixed in rawhide.  I
updated another system today with setools-1.2.1-7 which had the old
setools-devel installed and it was deleted.

However, I did hit a speed bump in that when up2date/rpm was
processing the setools package it got an rpm error and the whole
process terminated.  This left the update status a bit screwed up.  I
was updating a bumch of packages which included kernel-* and
setools-*.  When I manually "rpm -q" for various packages, kernel,
kernel-docs, kernel-source, setools, and setools-gui were not
installed (the remaining packages were the updated versions.

To make sure everything was OK, I manually ran "rpm -Uvh --force" to
install/reinstall each of the packages in the set being.  I am going
to try and reproduce it (reinstall the old setools-* and then use
up2date).  If I can I will bugzilla it.

Note You need to log in before you can comment on or make changes to this bug.