Bug 1206036 - Impossible to reduce the display brightness under the new kernel - Toshiba Z30 laptop
Summary: Impossible to reduce the display brightness under the new kernel - Toshiba Z3...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-26 07:41 UTC by Janusz
Modified: 2015-05-26 03:55 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-05-11 19:02:58 UTC


Attachments (Terms of Use)
dmi.log (12.05 KB, text/plain)
2015-03-26 15:33 UTC, Janusz
no flags Details

Description Janusz 2015-03-26 07:41:40 UTC
Description of problem:

When running the newest kernel (3.19.1-201.fc21.x86_64) on Toshiba Z30-B laptop the screen brightness is always very high and cannot be changed.

FN+F6 does not work, but it cannot be change using the brightness control in Gnome or in XFCE either.

The problem remains on the kernel from the Fedora Update Testing repository (3.19.2-200.fc21.x86_64)

It works on previous kernels, e.g. 3.17.4-301.fc21  3.18.9-200.fc21.x86_64


Version-Release number of selected component (if applicable):

Fedora 21, kernel 3.19.1-201.fc21.x86_64 and 3.19.2-200.fc21.x86_64

How reproducible:

Boot using the most recent kernel, and it does not work. Neither on GNOME nor on XFCE.  
Boot using an older kernel, and it works.

Additional info:
Toshiba Z30-B-119 laptop. Intel i5-5200U CPU. FHD screen. 
Fedora 21 64 bit.

Comment 1 Hans de Goede 2015-03-26 12:33:06 UTC
Hi,

Can you please try booting one of the new non working kernels with "video.use_native_backlight=0" added to the kernel commandline, and let us know if that fixes things.

Also please do:

sudo dmidecode > dmi.log

And attach the generated dmi.log file here please.

Thanks & Regards,

Hans

Comment 2 Janusz 2015-03-26 15:33:16 UTC
Hi,

I added "video.use_native_backlight=0" to the kernel command line and the result is a little surprising: 

the brightness control still does not work under the newest kernel (3.19.2-200.fc21.x86_64), but
it also stop working under the previous kernel (3.18.9-200.fc21.x86_64)

I also changed the value to 1 just to test what happens, and under the old kernel the brightness starts working normally but under the new kernel it still does not work. 

I am attaching the dmi.log

Thank you!
Janusz

Comment 3 Janusz 2015-03-26 15:33:46 UTC
Created attachment 1006865 [details]
dmi.log

Comment 4 Hans de Goede 2015-03-27 13:51:39 UTC
Hi,

Thanks for the testing and logs, can you please try using a newer kernel, e.g. :
http://koji.fedoraproject.org/koji/buildinfo?buildID=623735

Download the following rpms:
kernel-4...rpm
kernel-core-4...rpm
kernel-modules-4...rpm

For your arch from there,  save them all to the same directory (which should not contain other rpms) and do:

sudo rpm -ivh kernel-*.rpm

From within that directory.

Then reboot into the new kernel and see if that fixes things.

If that does not help can you please do:

ls /sys/class/backlight

And copy and paste the output from that command to this bug from 3 different boots:

1) An old working kernel
2) A new non working kernel without any special cmdline options
3) A new non working kernel with "video.use_native_backlight=0" on the kernel command line

Regards,

Hans

Comment 5 Janusz 2015-03-27 18:21:02 UTC
(In reply to Hans de Goede from comment #4)

Hi! 
The newest kernel did not help (4.0.0-0.rc5.git3.1.fc22.x86_64), but I see the solution is close, thanks to your help. 

The command ls /sys/class/backlight 
gives the following output


1/ for an old working kernel 

intel_backlight


2/ for a new non working kernel (last release and git)

intel_backlight
toshiba


3/ for a new non working kernel with "video.use_native_backlight=0"

acpi_video0
intel_backlight
toshiba



Thank you!
Janusz

Comment 6 Janusz 2015-04-01 06:27:27 UTC
Hi!

Waiting for the solution to be implemented in the kernel I figured I can do this:

echo 250 > /sys/class/backlight/intel_backlight/brightness

and adjust the brightness using the right number (e.g. 200, 250, 300, 400). 

It is not very convenient but it works.

I wonder if this can be implemented in the kernel so that the keyboard shortcut uses it. 

Thanks
Janusz

Comment 7 Hans de Goede 2015-04-10 08:10:05 UTC
Hi,

Ok, I think that this is caused by this upstream commit:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/drivers/platform/x86/toshiba_acpi.c?id=a39f46df33c6847399f9b41b74ef09a4095fb996

I've just started a scratch build of the fedora 3.19.3 kernel with that commit reverted:
http://koji.fedoraproject.org/koji/taskinfo?taskID=9452952

Please download the following rpms:
kernel-3.19.3-...rpm
kernel-core-3.19.3-...rpm
kernel-modules-3.19.3-...rpm

For your arch from there  (note this is still building atm).

Save them all to the same directory (which should not contain other rpms) and do:

sudo rpm -ivh kernel-*.rpm

From within that directory.

Then boot into the new kernel (without any special kernel commandline options) and check if the backlight works as expected.

Also please provide the output of:

ls -l /sys/class/backlight

On a *broken* kernel, so that we will know which version of the toshiba acpi interface your laptop has, as reverting the commit will cause a known issue on another model, so we need to figure out a way to make both models work.

Thanks & Regards,

Hans

Comment 8 Janusz 2015-04-10 12:23:05 UTC
With this new kernel the backlight works!

Here is the output of ls -l /sys/class/backlight on the broken kernel:

lrwxrwxrwx 1 root root 0 Apr 10  2015 intel_backlight -> ../../devices/pci0000:0
0/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight
lrwxrwxrwx 1 root root 0 Apr 10 14:15 toshiba -> ../../devices/LNXSYSTM:00/LNXSY
BUS:00/TOS6208:00/backlight/toshiba

Thanks you!
Janusz

Comment 9 Hans de Goede 2015-04-11 06:48:37 UTC
Thanks for testing, and for the requested info. So now we know the culprit we need to come up with a way to fix this which does not break other Toshiba models. I'm currently discussing this with the upstream toshiba driver maintainer, see: https://bugzilla.kernel.org/show_bug.cgi?id=86521

In the mean time it is probably best if you keep using the scratch build.

Comment 10 Janusz 2015-04-11 07:02:34 UTC
Thank you!

Comment 11 Hans de Goede 2015-04-14 09:36:39 UTC
Hi,

After discussing this with upstream we've come up with a different fix, see:
https://bugzilla.kernel.org/show_bug.cgi?id=86521 for details.

I've started a new scratch-build with this fix, can you please test this once it is done building ?  :

http://koji.fedoraproject.org/koji/taskinfo?taskID=9475621

The test instructions are the same as before, note the kernel version now ends with rhbz1206036_2
the _2 is there so that you can distuingish this from the previous scratch build.

Thanks & Regards,

Hans

Comment 12 Janusz 2015-04-14 15:08:12 UTC
Hi,

It works well!  
(I tested 3.19.3-200.rhbz1206036_2.fc21.x86_64)

Thank you 
Janusz

Comment 13 Hans de Goede 2015-04-15 14:12:54 UTC
Hi,

(In reply to Janusz from comment #12)
> Hi,
> 
> It works well!  
> (I tested 3.19.3-200.rhbz1206036_2.fc21.x86_64)
> 
> Thank you 
> Janusz

Thanks I've submitted the patch upstream, once it is accepted upstream I'll look into adding it to the official Fedora kernel builds, in the mean time it is probably best to keep using the second scratch build I've done.

Regards,

Hans

Comment 14 Janusz 2015-04-16 06:15:11 UTC
Thank you. I appreciate your effort.

Regards,
Janusz

Comment 15 Janusz 2015-04-20 13:19:45 UTC
Hi,

Unfortunately I discovered a strange bug in the second scratch build (3.19.3-200.rhbz1206036_2.fc21.x86_64)

It does not happen under the previous kernels. The previous scratch build works correctly as well. 
(I've tested 3.18.9-200.fc21.x86_64 and 3.19.3-200.rhbz1206036.fc21.x86_64).

The problem description:

When I connect an external display before opening a session (when the login screen is displayed) the laptop freezes and the only solution is to keep the power button pressed until the PC is powered off. (Strangely enough I can see the login screen and the mouse pointer but everything else is frozen, even ctrl+alt+F2 does not work.) 

When the external display is switched on during the session, it works, but the computer freezes when I log out. 

This affects both HDMI and VGA outputs.

I am sorry I have not seen it before, but I was travelling and have not used any external display.


Regards,
Janusz

Comment 16 Hans de Goede 2015-04-20 14:39:53 UTC
Hi,

Do you still have the kernel from the first scratchbuild installed ? If so can you give that one a try and see if you can reproduce it there too? This sounds like an issue which is not related to the backlight fix, but likely something else which has broken in the newer kernels.

Regards,

Hans

Comment 17 Janusz 2015-04-20 15:35:51 UTC
Hi,

You are right, the first scratch build has the same issue. I just haven't noticed it.

I just tested 4.0.0.* kernel and it has the same bug. 

I guess I should report it as a separate bug, right?


Thanks 
Janusz

Comment 18 Hans de Goede 2015-04-20 18:02:39 UTC
Hi,

(In reply to Janusz from comment #17)
> Hi,
> 
> You are right, the first scratch build has the same issue. I just haven't
> noticed it.
> 
> I just tested 4.0.0.* kernel and it has the same bug. 
> 
> I guess I should report it as a separate bug, right?

Yes please.

Thanks,

Hans

Comment 19 Fedora Kernel Team 2015-04-28 18:29:57 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.19.5-200.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 22, and are still experiencing this issue, please change the version to Fedora 22.

If you experience different issues, please open a new bug report for those.

Comment 21 Josh Boyer 2015-04-30 23:49:32 UTC
The patch has been added and will be in the 3.19.6 builds on F20/F21.  F22 will get a build soon.

Comment 22 Janusz 2015-05-01 06:07:20 UTC
Thank you! I appreciate it.

Comment 23 Fedora Update System 2015-05-01 16:26:17 UTC
kernel-3.19.6-200.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.19.6-200.fc21

Comment 24 Fedora Update System 2015-05-01 16:31:10 UTC
kernel-3.19.6-100.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.19.6-100.fc20

Comment 25 Fedora Update System 2015-05-02 18:09:55 UTC
Package kernel-3.19.6-100.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.19.6-100.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7442/kernel-3.19.6-100.fc20
then log in and leave karma (feedback).

Comment 26 Janusz 2015-05-02 20:16:36 UTC
The issue was fixed. (tested using 3.19.6-200.fc21.x86_64)

Thank you!
Janusz

Comment 27 Fedora Update System 2015-05-08 12:18:06 UTC
kernel-4.0.2-300.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kernel-4.0.2-300.fc22

Comment 28 Fedora Update System 2015-05-08 16:09:48 UTC
kernel-3.19.7-100.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.19.7-100.fc20

Comment 29 Fedora Update System 2015-05-08 16:12:27 UTC
kernel-3.19.7-200.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.19.7-200.fc21

Comment 30 Fedora Update System 2015-05-11 19:02:58 UTC
kernel-4.0.2-300.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2015-05-12 20:40:47 UTC
kernel-3.19.7-200.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 32 Fedora Update System 2015-05-18 17:32:31 UTC
kernel-3.19.8-100.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.19.8-100.fc20

Comment 33 Fedora Update System 2015-05-26 03:55:51 UTC
kernel-3.19.8-100.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.