Bug 120605 - udev has no init scripts
Summary: udev has no init scripts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-04-11 22:29 UTC by David Zeuthen
Modified: 2014-03-17 02:44 UTC (History)
2 users (show)

Fixed In Version: 7.62-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 04:54:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for initscripts (1.06 KB, patch)
2004-07-02 09:35 UTC, Harald Hoyer
no flags Details | Diff
better patch against rc.sysinit cvs version (918 bytes, text/plain)
2004-07-02 09:37 UTC, Harald Hoyer
no flags Details
better patch against rc.sysinit cvs version (918 bytes, patch)
2004-07-02 09:37 UTC, Harald Hoyer
no flags Details | Diff

Description David Zeuthen 2004-04-11 22:29:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
udev already ships with initscripts to rebuild /dev at boot but these
are not installed in the package.

Version-Release number of selected component (if applicable):
udev-023-1

How reproducible:
Always

Steps to Reproduce:
1. install udev
2. see there is no initscripts for udev
    

Actual Results:  after reboot /dev still contains 18000 or so files.

Expected Results:  /dev should be minimal and only represent the
devices available in the system

Additional info:

Comment 1 David Zeuthen 2004-04-19 21:25:39 UTC
Oh, I forgot to mention that another issue with no initscripts is that
the udev database located at /dev/.udev.tdb is not initialised with
appropriate data. This means that udevinfo doesn't work as intended,
for example 

david@laptop:~/xdg-hacking/hal$ udevinfo -r -q name -p /block/hda
/dev/hda

won't work which is a problem when using freedesktop.org hal.


Comment 2 Harald Hoyer 2004-04-20 08:23:18 UTC
rc.sysinit will/should call /sbin/udevstart 

Comment 3 Harald Hoyer 2004-07-02 09:35:44 UTC
Created attachment 101586 [details]
patch for initscripts

with this patch udev gets started

Comment 4 Harald Hoyer 2004-07-02 09:37:40 UTC
Created attachment 101587 [details]
better patch against rc.sysinit cvs version

Comment 5 Harald Hoyer 2004-07-02 09:37:43 UTC
Created attachment 101588 [details]
better patch against rc.sysinit cvs version

Comment 6 Bill Nottingham 2004-08-19 04:54:02 UTC
Added, will be in 7.62-1.


Note You need to log in before you can comment on or make changes to this bug.