Bug 1206117 - Disabled display comes out again after uncheck it
Summary: Disabled display comes out again after uncheck it
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-vdagent   
(Show other bugs)
Version: 6.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Fabiano Fidêncio
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-26 10:54 UTC by zhoujunqin
Modified: 2015-07-22 07:28 UTC (History)
11 users (show)

Fixed In Version: spice-vdagent-0.14.0-7.el6
Doc Type: Bug Fix
Doc Text:
Consequence: Sometimes, when trying to disable an additional display from remote-viewer menu, the disabled display would immediatly get reenabled. Result: After this fix, disabled displays no longer unexpectedly come back.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 07:28:08 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer debug log (16.37 KB, text/plain)
2015-03-26 10:54 UTC, zhoujunqin
no flags Details
with --debug --spice-debug (519.69 KB, text/plain)
2015-03-27 02:45 UTC, zhoujunqin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1392 normal SHIPPED_LIVE spice-vdagent bug fix update 2015-07-20 17:58:05 UTC

Description zhoujunqin 2015-03-26 10:54:08 UTC
Created attachment 1006761 [details]
virt-viewer debug log

Description of problem:
Disabled display comes out again after uncheck it

Version-Release number of selected component (if applicable):
virt-viewer-2.0-4.el6.x86_64
spice-gtk-0.26-3.el6.x86_64
gtk-vnc-0.3.10-3.el6.x86_64

How reproducible:
often(70%)

Steps to Reproduce:
1. Prepare a rhel guest with spice + qxl + spicevmc
2. Configure the guest with only 1 display, use virt-viewer to connect it.
#virt-viewer vm

3. View - > Displays - > Check Display2,3,4 all.

4. Uncheck Display 3.(May need try several times)

Actual results:
Display 3 appear again.

Expected results:
Uhchecked display 3 should not appear again.

Additional info:
1. I will attach virt-viewer debug log.

Comment 1 Marc-Andre Lureau 2015-03-26 10:56:32 UTC
Could you check if it's a regression? thanks

Comment 3 Fabiano Fidêncio 2015-03-26 22:38:13 UTC
Can you get a spice log as well? It's not being so easy to reproduce it here ...
(run virt-viewer --debug --spice-debug ...)

Comment 4 zhoujunqin 2015-03-27 02:44:13 UTC
(In reply to Fabiano Fidêncio from comment #3)
> Can you get a spice log as well? It's not being so easy to reproduce it here
> ...
> (run virt-viewer --debug --spice-debug ...)

Yes, it's not easy to reproduce it, may you need try check/uncheck display for several times.

Just now i reproduce it again and i will attach debug log again, thanks.

# virt-viewer  6-x64 --debug --spice-debug |& tee >all_debug

Comment 5 zhoujunqin 2015-03-27 02:45:07 UTC
Created attachment 1007069 [details]
with --debug --spice-debug

Comment 6 Fabiano Fidêncio 2015-04-07 13:09:46 UTC
I cannot reproduce the problem with a newer version vdagent.
I'm providing you a scratch build (with the possible fix included). Can you, please, try to reproduce the issue with the provided build?

https://brewweb.devel.redhat.com/taskinfo?taskID=8950283

Comment 7 zhoujunqin 2015-04-08 03:07:00 UTC
Hi  Fabiano Fidêncio,

I can reproduce this issue:
with guest installed by iso: RHEL-6.6-20140926.0-Server-x86_64-dvd1.iso 
pkg version: spice-vdagent-0.14.0-4.el6.x86_64

Then tried with scratch build:
1. Update pkg spice-vdagent both on host and guest to new version:

# rpm -q spice-vdagent
spice-vdagent-0.14.0-99.el6.x86_64

2. Use virt-viewer to connect guest and do as Comment 0 described:
# virt-viewer  6-x64

Result: Tried several times but cannot reproduce bug issue any more.

Comment 8 Fabiano Fidêncio 2015-04-08 07:35:52 UTC
Okay. Just for the record, the patch that solves the problem is 9ae51f3702b1fc0d2747e44474c87a818d1e8ec3, on linux vd-agent.

Comment 10 errata-xmlrpc 2015-07-22 07:28:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1392.html


Note You need to log in before you can comment on or make changes to this bug.