Bug 120613 - mouse button 4 not reported correctly
Summary: mouse button 4 not reported correctly
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-12 04:57 UTC by Simon Rademacher
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 08:10:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log (50.30 KB, text/plain)
2004-04-12 05:08 UTC, Simon Rademacher
no flags Details

Description Simon Rademacher 2004-04-12 04:57:35 UTC
Description of problem:
Using a Logitech TrackMan Marble FX connected via PS2, button 4 is
reported as button 1.


Version-Release number of selected component (if applicable):
Name        : xorg-x11
Version     : 0.6.6
Release     : 0.2004_03_30.5                Build Date: Tue 06 Apr
2004 11:49:44 PM MDT


How reproducible:
Always


Steps to Reproduce:
1. launch xev
2. press button 4 (small red button on aforementioned device)
3.
  
Actual results:
observe output of xev reporting press and release of button 1

Expected results:
Should be reporting button 4

Additional info:
Buttons 1, 2, 3 report correctly.

Comment 1 Simon Rademacher 2004-04-12 05:08:37 UTC
Created attachment 99319 [details]
X server log

Comment 2 Simon Rademacher 2004-04-12 05:12:06 UTC
XF86Config file has:
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "MouseManPlusPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "Buttons" "7"
        Option      "EmulateWheel" "true"
        Option      "EmulateWheelButton" "4"
        #Option      "EmulateWheelInertia" "50"
        Option      "XAxisMapping" "6 7"
        Option      "YAxisMapping" "4 5"
        #Option     "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

This configuration worked with RedHat 9's XFree86 packages (with
appropriate device string).

Comment 3 Kristian Høgsberg 2004-08-26 17:10:19 UTC
The wheel button is absorbed by the mouse driver, so you can not use
that button for other purposes.  Your config section in comment 2 sets
button 4 as the wheel button, so this would explain it.

Comment 4 Simon Rademacher 2004-08-27 03:09:11 UTC
I didn't get the expected results correct. Pressing button 4 by itself
should not report any event, as you say. Pressing it and moving the
track ball should report buttons 4, 5, 6, or 7, depending on
direction, as given by the X and Y axis mappings.

It should not be reporting button 1, though.


Comment 6 Mike A. Harris 2004-08-27 08:10:04 UTC
I also agree with Kristian above for this issue.  It seems to
be misconfiguration resulting in unexpected behaviour.  Your best
bet is to subscribe to the xorg@freedesktop.org mailing list and
ask for help configuring the mouse to have the behaviour you
expect.  That way it will be clear what is wrong with your
configuration, or wether there is a legitimate bug being triggered
here.

If it does turn out there is a bug being triggered, then please
file a bug report in the X.org bugzilla and cut and paste the
bug URL here and we will track the issue in their bugzilla
centrally.

Setting status to "NOTABUG".

Comment 7 Simon Rademacher 2004-08-27 21:13:33 UTC
The configuration given above worked in RH9 (and previous versions,
don't know how far back exactly: from when EmulateWheel and
XAxisMapping was added to X) and it works in Mandrake 9.2. I'll look
into reporting it to Xorg.



Note You need to log in before you can comment on or make changes to this bug.