Bug 1206216 - Virtual desktops, mouse actions goes to wrong display.
Summary: Virtual desktops, mouse actions goes to wrong display.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Grunt
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1205601
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-26 14:58 UTC by Pavel Grunt
Modified: 2015-07-22 06:32 UTC (History)
14 users (show)

Fixed In Version: virt-viewer-2.0-5.el6
Doc Type: Bug Fix
Doc Text:
In multi-display guest setups, the mouse input in some cases affected an incorrect guest display. With this update, displays are properly reordered when their coordinates change, and mouse input reliably affects the appropriate guest display.
Clone Of: 1205601
Environment:
Last Closed: 2015-07-22 06:32:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 17:53:14 UTC

Description Pavel Grunt 2015-03-26 14:58:26 UTC
+++ This bug was initially created as a clone of Bug #1205601 +++

Description of problem:
Actions from mouse destined for Display 1 go to Display 2
And vice verse.
Actions for Display 2 go to Display 1

Version-Release number of selected component (if applicable):
virt-viewer-2.0-1.fc21.x86_64
spice-xpi-2.8.90-6.fc21.x86_64
spice-glib-0.27-3.fc21.x86_64
spice-gtk3-0.27-3.fc21.x86_64
spice-vdagent-0.15.0-3.fc21.x86_64
spice-server-0.12.5-5.fc21.x86_64

How reproducible:
80 %

Steps to Reproduce:
1. virt-viewer -c qemu:///system RHEL-6.6-WS
2. Open second display View->Display->Display2

Actual results:
Events for Display1 go to Display2

See screenshot.

--- Additional comment from Fabiano Fidêncio on 2015-03-25 06:15:51 EDT ---

May I ask you to provide some logs?
In order to get virt-viewer and spice-gtk debug, please, run: "virt-viewer -c qemu:///system RHEL-6.6-WS --debug --spice-debug"

--- Additional comment from Pavel Grunt on 2015-03-25 09:48:54 EDT ---

I can reproduce it using:
virt-viewer-2.0-3.el6.x86_64

--- Additional comment from RHEL Product and Program Management on 2015-03-25 09:50:48 EDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Cole Robinson on 2015-03-25 10:10:22 EDT ---

RWIW just reassigning a fedora bug to RHEL generally isn't a good idea, the reporter probably doesn't care about RHEL. Better to clone the bug instead

Comment 3 Pavel Grunt 2015-04-09 09:01:42 UTC
fixed by commit: 310979947594bbbab39c4b1b25823cf0a2e56e93

Comment 5 zhoujunqin 2015-04-13 10:55:50 UTC
I can reproduce this issue with package:
virt-viewer-2.0-3.el6.x86_64

steps:
1. Prepare a health guest, and use virt-viewer to connect it.
# virsh dumpxml 6-x64
...
    <graphics type='spice' port='5900' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>
...

# virt-viewer -c qemu:///system 6-x64

2. move virt-viewer's window(Display 1) as right as possible.

3. open new display (it should apper on the left to the first window)

4. right click mouse or right click a icon on desktop.

Result: context appears on the other window.

Then try to verify this bug on new build:
virt-viewer-2.0-5.el6.x86_64

Steps:
1. Prepare a health guest, and use virt-viewer to connect it.
# virt-viewer -c qemu:///system 6-x64

2. move virt-viewer's window(Display 1) as right as possible.

3. open new display (it should apper on the left to the first window)

4. right click mouse or right click a icon on desktop.

Result: context appears on the current window.

And repeat above steps several times, cannot reproduce this issue again, so move this bug from ON_QA to VERIFIED.

Comment 6 errata-xmlrpc 2015-07-22 06:32:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html


Note You need to log in before you can comment on or make changes to this bug.