Bug 1206243 - Api for available_clusters on vmware does not return expected value.
Summary: Api for available_clusters on vmware does not return expected value.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Sanket Jagtap
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-26 15:52 UTC by ldomb
Modified: 2019-11-14 06:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:14:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11345 None None None 2016-04-22 15:53:27 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description ldomb 2015-03-26 15:52:03 UTC
Description of problem:

I have a VMware cluster with the following setup

Datacentername = nyc
Clustername = nyccluster

I have 2 hosts in the cluster and I am able to provision to it via sat6. 

When I try to query the vmware cluster information via api

https://sat6.local.domb.com/api/v2/compute_resources/4/available_clusters

I get back 

{
  "total": 4,
  "subtotal": 4,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [{}]
}

This only happens with vmware. If I choose rhev it works
https://sat6.local.domb.com/api/v2/compute_resources/3/available_clusters

{
  "total": 4,
  "subtotal": 4,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [{"name":"Default","id":"00000001-0001-0001-0001-00000000034c"}]
}

Version-Release number of selected component (if applicable): 6.0.8


How reproducible:


Steps to Reproduce:
1. You need to have a vmware cluster :-)
2. Query the api of sat6 
https://SAT6SERVER/api/v2/compute_resources/3/available_clusters

Actual results:
results hash is empty 

Expected results:
results hash should contain vmware cluster

Additional info:

Comment 1 RHEL Program Management 2015-03-26 16:03:36 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2015-03-26 16:25:08 UTC
Created redmine issue http://projects.theforeman.org/issues/9911 from this bug

Comment 5 Bryan Kearney 2015-08-25 18:34:40 UTC
Upstream bug component is Provisioning

Comment 6 Bryan Kearney 2015-08-26 19:20:29 UTC
Upstream bug component is Compute Resources

Comment 7 Tomer Brisker 2016-02-29 13:26:46 UTC
Fixed upstream for 1.10 under a different issue number, moving to post and updating the related issue.

Comment 9 Sanket Jagtap 2016-04-22 08:46:37 UTC
Works for vmware cluster

/api/v2/compute_resources/1/available_clusters

Build: snap9.0

Output:

{
  "total": 1,
  "subtotal": 1,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [{"name":"CFME-ESX55-Cluster","id":"domain-c241","full_path":"CFME-ESX55-Cluster"}]
}

Comment 11 errata-xmlrpc 2016-07-27 09:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.