Bug 120626 - Kernel boot kills USB after successfully loading it
Kernel boot kills USB after successfully loading it
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Depends On:
  Show dependency treegraph
Reported: 2004-04-12 08:59 EDT by raxet
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-18 00:43:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description raxet 2004-04-12 08:59:03 EDT
Description of problem:
Custom kernel boot fine until after loading HARDWARE detect then USB
dies, mouse, keyboard unresponive

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot kernel
Actual results: unresponsive keyboard and mouse

Expected results:
Boot normally

Additional info:
Comment 1 Ralf Ertzinger 2004-04-13 13:03:34 EDT
This might be caused by something entirely different.

Somewhere around kernel release 290 something changed in the kernel
which causes /etc/rc.sysinit to believe that the USB driver is already
loaded (although it is not). I do not have the exact release at hand,
but this is (from my point of view) not an initscript bug, because
earlier kernels worked fine with the same /etc/rc.sysinit.

Adding the line "/sbin/modprobe usb-controller" to /etc/rc.local
"fixes" the problem, and the driver works just as expected afterwards.

However, hhis does not help with USB keyboards during the boot process.
Comment 2 raxet 2004-04-16 04:39:21 EDT
Same issue with kernel 2.6.5-1.322, haven't given .326 a try.
Ralf's idea with /sbin/modprobe usb-controller still doesn't affect a
resolution (temp) for restoring USB keyboards.
Comment 3 Andrew Farris 2004-04-16 14:55:34 EDT
I have the same issue with my Dell Precision WS340.
00:00.0 Host bridge: Intel Corp. 82850 850 (Tehama) Chipset Host
Bridge (MCH) (rev 04)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 04)
(prog-if 00 [UHCI])

I have these additions to /etc/rc.d/rc.local, however I believe only
hid needs to be there for usb to become active again just prior to
login, for any runlevel.  Occassionally I must unplug/replug the usb
keyboard before it is powered.  The problem did start right near
-1.290, this is the same for Rawhide and my customs (mainstream and
Rawhide src.rpm rebuilds).  Currently I cannot use the USB keyboard
during the boot process.

/sbin/modprobe uhci-hcd
/sbin/modprobe hid
/sbin/modprobe usbcore

Comment 4 raxet 2004-04-17 06:15:11 EDT
2.6.5-1.326 makes no change to present condition. Another annoyance
though not of real import is that kudzu can't be accessed, so you
might as well turn it off before doing anything else. I don't need
usbcore in rc.local either :)
Comment 5 raxet 2004-04-17 06:22:21 EDT
Also what is annoying, you can't check your file system, potentially
fatal at some point :)
Comment 6 raxet 2004-04-18 00:43:34 EDT
Fixed with new initscripts-7.50-1

Note You need to log in before you can comment on or make changes to this bug.