Bug 1206264 - Clear all option in RHEV admin portal does not clear any alerts
Summary: Clear all option in RHEV admin portal does not clear any alerts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.1
: ---
Assignee: Ravi Nori
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-26 16:40 UTC by Jake Hunsaker
Modified: 2019-07-16 11:32 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update adjusts the behavior of the Clear All action in the alerts footer tab in the Administration Portal. Previously, Clear All cleared all actions run by the user to hide alerts, and displayed all cleared alerts in the alerts panel. The Clear All action now dismisses all alerts and events in that list. This fix also adds the Display All action to show all alerts and events. Additionally, an issue has been fixed where actions on the events footer tab affected the alerts tab, and as a result, clearing or displaying all events was simultaneously also applied to the list of alerts. This has been fixed and now operations done on the events tab affects only events.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:01:12 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 39579 master MERGED engine, webadmin: Clear all option in RHEV admin portal does not clear any alerts Never
oVirt gerrit 46253 master MERGED engine, webadmin: Clear all option in RHEV admin portal does not clear any alerts Never
oVirt gerrit 47089 ovirt-engine-3.6 MERGED engine, webadmin: Clear all option in RHEV admin portal does not clear any alerts Never
Red Hat Bugzilla 988392 None CLOSED PRD35 - [RFE] Ability to dismiss alerts from web-admin portal 2019-07-16 11:34:44 UTC

Internal Links: 988392

Description Jake Hunsaker 2015-03-26 16:40:16 UTC
Description of problem:

Selecting "clear all" from the alerts pane does not clear any alerts from the portal.

Version-Release number of selected component (if applicable):
rhevm-3.5.0-0.32

How reproducible:
Always

Steps to Reproduce:
1. Right click and select "clear all" from the alerts pane
2.
3.

Actual results:
No alerts are cleared

Expected results:
All alerts are cleared

Additional info:

Comment 2 Einav Cohen 2015-03-27 13:56:30 UTC
@Ravi, any idea?

Comment 3 Ravi Nori 2015-03-27 14:19:01 UTC
"Clear All" clears all actions by user to hide alerts and will display all alerts. So it displays all cleared alerts in the alerts panel.

So IMO this should be closed as NOT A BUG

Comment 4 Jake Hunsaker 2015-03-27 19:39:18 UTC
That...doesn't sound like a proper use for a "Clear all" option to me. When presented with a "clear all" option anywhere my only thought is "ok, this will remove every entity currently listed".


Perhaps then this should be an RFE to change the Clear All behavior? And rename the current "clear all" to "display all"?

Comment 5 Oved Ourfali 2015-03-30 07:35:16 UTC
Einav - thoughts?

Comment 6 Einav Cohen 2015-03-30 17:31:51 UTC
(In reply to Jake Hunsaker from comment #4)
> That...doesn't sound like a proper use for a "Clear all" option to me. When
> presented with a "clear all" option anywhere my only thought is "ok, this
> will remove every entity currently listed".
> 
> 
> Perhaps then this should be an RFE to change the Clear All behavior? 
> And rename the current "clear all" to "display all"?

should we have both "clear all" and "display all"?
if so - I recommend tracking 'renaming the current "clear all" to "display all"' and 'properly implement "clear all"' in separate BZs (i.e. have this BZ track one of the issues, and open a new BZ to track the other issue), unless it is quick and easy to do both (renaming is probably easy, but I'm not sure about proper "clear all" implementation). 

if we shouldn't have both "clear all" and "display all": it doesn't make sense to 'change the Clear All behavior *AND* rename the current "clear all" to "display all"' - need to do only one of these changes (and this BZ should track the chosen change).

Comment 7 Ravi Nori 2015-04-06 15:03:07 UTC
Supporting both "clear all" and "display all"

Comment 8 Max Kovgan 2015-06-28 14:12:37 UTC
ovirt-3.6.0-3 release

Comment 9 Lukas Svaty 2015-09-16 10:16:46 UTC
Behaviour is still a bit not user friendly see this flow:
Notation: 
Events = Messages (successful actions) + Alerts

Steps
1. Events tab showing all Messages and Alerts
2. In Events tab click 'Clear All'
3. All Events (Messages + Alerts) are cleared from both Events and Alerts tab
4. In Events tab click 'Display All'
5. All Messages re-appear (No Alerts are displayed though => bug)

To show again Alerts in Events tab, admin has to navigate to Alerts tab, click 'Display All', Alerts will be displayed in Alerts tab, if he wants to see all Events of system (alerts+messages) he have to navigate back to Events tab and see all Events (Messages and Alerts).

More promising seems to me option that, 'clear/display all' in Alerts tab has current functionality (dismiss and display all alerts, in Alerts and also in Events tab)

and

'clear/display all' in events tab do the same with all events (messages as well as alerts) so when trying to display all in Events tab alerts are displayed also. 

What do you think?

Comment 10 Ravi Nori 2015-09-16 13:24:17 UTC
I think the correct behavior should be that alerts tab actions don't effect events and event tab actions don't effect alerts .

Will submit a patch for that

Comment 11 Oved Ourfali 2015-09-16 13:25:13 UTC
(In reply to Ravi Nori from comment #10)
> I think the correct behavior should be that alerts tab actions don't effect
> events and event tab actions don't effect alerts .
> 
> Will submit a patch for that

makes sense to me as well.

Comment 12 Lukas Svaty 2015-10-15 14:27:05 UTC
current version rhevm-webadmin-portal-3.6.0.1-0.1.el6.noarch has the same behaviour as mentioned in comment#9. 

Please provide fixed in version information and/or move to MODIFIED if the patch is not included in 3.6.0.1-0.1. 

If it was included in this version, it will FailQA.

Comment 13 Ravi Nori 2015-10-15 16:15:07 UTC
Please see comment 10 & 11, the actions on Alert tab should not effect events and the actions on events tab should not effect alerts.

Comment 14 Jake Hunsaker 2015-10-15 16:23:00 UTC
I would agree with comment 10 - alert tab and events tab should not effect one another.

Comment 15 Oved Ourfali 2015-10-15 17:00:25 UTC
Moving back to modified. The bug has 3.6.1 target milestone.

Comment 16 Lukas Svaty 2015-11-05 13:48:26 UTC
rhevm-webadmin-portal-3.6.0.3-0.1.el6.noarch

still the same behaviour as comment#9
moving back to ASSIGNED

Easy fix for this might be to remove Alerts from the Events tab, this way Display/Clear Alerts/Events will be done only on those in the already chosen tab.

Comment 17 Oved Ourfali 2015-11-05 13:53:16 UTC
Ravi - please check what should be changed.
Targeting to 3.6.1.
At first I thought it was only in 3.6.1, but seems like it was merged to 3.6.0 as well.

If needed, please provide an environment for Lukas to access and validate.

Comment 18 Oved Ourfali 2015-11-05 14:15:51 UTC
Okay.
The fixed consisted of several patches.
Some were in 3.6 and some only in 3.6.1.
The latest one is http://gerrit.ovirt.org/47089 which is only in 3.6.1.

Moving back to MODIFIED.
This SHOULD NOT move to ON_QA before 3.6.1 is built.

Comment 19 Lukas Svaty 2015-11-26 11:56:28 UTC
verified in 1263323 - Add new host, error message not shown

Comment 22 errata-xmlrpc 2016-03-09 21:01:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.