Bug 120628 - Please include DECnet in Fedora kernel
Please include DECnet in Fedora kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 09:31 EDT by Christine Caulfield
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 16:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2004-04-12 09:31:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
Is it possible that the DECnet module could be included in the Fedora
kernel, if only in the unsupported section. The correct configuration
for 2.6 is as follows:

CONFIG_DECNET=y
# CONFIG_DECNET_SIOCGIFCONF is not set
CONFIG_DECNET_ROUTER=y

DECnet is perfectly usable and stable in 2.6 (except on big-endian
platforms) and, although not a major feature, is used by quite a few
people. If it is included in the default kernel for fedora then it
will, at least, obviate the need for them to rebuild their kernel.

I am packaging the userland programs so I'll take care of any
DECnet-related problems that may occur!
Comment 1 Alan Cox 2004-05-03 08:12:05 EDT
CONFIG_DECNET=m I can just about see. CONFIG_DECNET=y no chance!
Comment 2 Christine Caulfield 2004-05-04 08:57:36 EDT
CONFIG_DECNET=m is, of course, what I really meant. Sorry.
Comment 3 Dave Jones 2004-05-07 17:40:42 EDT
It's too late in the game to change this. If we change this in the
kernel, it breaks userspace. We made this mistake briefly in FC1.
Without a complete rebuild of userspace using the networking headers,
this has no chance of working.

Try again for FC3 test1
Comment 4 Christine Caulfield 2004-05-08 05:48:25 EDT
I don't think that's strictly true. What broke userspace in FC1 was
also selecting CONFIG_DECNET_SIOCGIFCONF. Just creating a DECnet
module should have no impact on any userspace programs at all.

However, I'm not in any real rush...
Comment 5 Dave Jones 2004-05-08 20:25:40 EDT
actually, in 2.4 it broke because the size of struct sock changed
depending on which protocols were enabled.  This has been changed in
2.6, so that shouldn't be an issue.  It still makes me nervous at this
stage in the game however.
Comment 7 Dave Jones 2006-04-18 16:54:47 EDT
enabled in tomorrows rawhide.

Note You need to log in before you can comment on or make changes to this bug.