Bug 120637 - fam updates stopped working in FC2
fam updates stopped working in FC2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 11:37 EDT by Luke Hutchison
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 10:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Hutchison 2004-04-12 11:37:34 EDT
fam updates stopped working in FC2.  I have observed this for both
Test 1 and Test 2, on three different machines, with both local files
and NFS mounts.  Two machines were upgraded from earlier RH
installations, one was a fresh install.

As a result, Nautilus does not reflect directory or file changes.
Comment 1 Luke Hutchison 2004-04-12 22:17:59 EDT
On one machine I was just working on, starting fam manually (and then
re-running nautilus) actually fixed the problem.  Is this an xinetd issue?

Comment 2 Luke Hutchison 2004-04-12 23:14:36 EDT
Hmm...

/etc/xinetd.d/sgi_fam:

# default: off
# description: FAM is a file monitoring daemon. It can \
# be used to get reports when files change.
#
# The daemon conflicts with selinux, so you must boot
# with selinux disabled to use this.
service sgi_fam
{
[...]
	disable      = yes
}


Is there no way to write a policy file that gives fam unlimited rights
to monitor file/directory status?
Comment 3 Luke Hutchison 2004-04-12 23:19:57 EDT
Even setting "disable=no" and then restarting xinetd doesn't fix the
problem (i.e. doesn't cause nautilus to start fam when it launches),
on a RH9 system without an selinux-enabled kernel.
Comment 4 Alexander Larsson 2004-04-13 10:49:24 EDT
Fam was disabled because it doesn't work with selinux at all. We're
working on a long term fix though.
Comment 5 Luke Hutchison 2004-04-13 20:08:26 EDT
OK -- any chance of setting up Nautilus so that it polls, until the
long term fix is in place?
Comment 6 Alexander Larsson 2004-04-16 11:53:40 EDT
fam is enabled again, since we disabled selinux.

Note You need to log in before you can comment on or make changes to this bug.