Bug 120665 - Kernel panic on boot
Kernel panic on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 15:41 EDT by cac
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-02 21:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cac 2004-04-12 15:41:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040312

Description of problem:
During boot:

  Creating root device
  mkrootdev: label / not found

followed by:

  kernel panic: no init found

System boots with kernel-2.4.22-1.2115.nptl

Earlier in the boot process, the partition check is not listing the
disk  partitions correctly. 

Under the 2.4 kernel I see:

  Partition check:
   hda: [EZD] [remap 0->1] [1467/255/63] hda1 hda2 hda3 < hda5 hda6 >

Under the 2.6 kernel I see:

   hda: [EZD] hda1

I added some printks to fs/partition/msdos.c and #defined DEBUG in
drivers/ide/ide-disk.c and drivers/ide/ide-io.c

These showed that the driver was claiming to read blocks 0-7 of hda,
and that the correct buffer address was being passed to msdos.c.
However, the data in the buffer does not match the contents of the  
disk. Oddly, the MSDOS_MAGIC (AA 55) at offset 510 is there, so there
maybe a data corruption problem.

The problem occurs on both reboot and cold-start.

The problem occurs with "acpi=off apm=off" as kernel parameters.

This problem seems to be occuring to handful of other people (google:
fedora mkrootdev), but they haven't noticed that the partition table
is missing, and are wild goose chasing on disk labels.

My hardware is Toshida laptop, Portege 3015CT which has being
successfully runing Linux for along time (RedHat 8.x, 9, Fedora Core 1).

Processor: Mobile Pentim MMX
dmesg from 2.4.22:

  RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
  Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
  ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
  hda: IBM-DARA-212000, ATA DISK drive
  ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
  hda: attached ide-disk driver.
  hda: host protected area => 1
  hda: 23579136 sectors (12073 MB) w/418KiB Cache, CHS=1467/255/63
  Partition check:
   hda: [EZD] [remap 0->1] [1467/255/63] hda1 hda2 hda3 < hda5 hda6 >
  ide: late registration of driver.



Version-Release number of selected component (if applicable):
2.6.5-1.308, 2.6.5-1.309, 2.6.5-1.315

How reproducible:
Always

Steps to Reproduce:
1. Boot 2.6.1-1.315 kernel
2.
3.
    

Actual Results:  Kernel panic: no init found

Expected Results:  login:

Additional info:
Comment 1 cac 2004-04-12 16:38:17 EDT
Sigh. Happens every time. File a bug, then understand the problem.

2.6 does not seem to be recognizing EZDrive. Adding "hda=remap" allows
booting.

Note You need to log in before you can comment on or make changes to this bug.