Bug 1206762 - Airplane mode does not work on KDE
Summary: Airplane mode does not work on KDE
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-networkmanager-qt
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-28 10:35 UTC by Giulio 'juliuxpigface'
Modified: 2015-03-30 08:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-30 08:05:02 UTC


Attachments (Terms of Use)

Description Giulio 'juliuxpigface' 2015-03-28 10:35:57 UTC
Description of problem:

While testing Fedora 22 (Beta-TC5) on KVM, installed from a KDE live, I experience this issue. Checking the option "Airplane mode" on the panel's applet, doesn't actually turn network off.

Version-Release number of selected component (if applicable):
kf5-networkmanager-qt-5.8.0-1.fc22.x86_64

Steps to Reproduce:
1. Boot the system and log into a KDE session.
2. Try to ping www.google.it in order to ensure networking is enabled and working.
3. Check the checkbox with the airplane in the network applet.
4. Try again to ping www.google.it and see if it's reachable

Actual results:
1. The checkbox remains checked, but networking stays enabled.

Expected results:
1. The checkbox remains checked, and networking should be turned off.

Additional info:
I'm running the system on KVM, but this issue doesn't apply with a Workstation guest (though the updates were applied there, where this KDE guest is a 'pure' TC5 system).

Comment 1 Fedora Blocker Bugs Application 2015-03-30 06:02:44 UTC
Proposed as a Blocker for 22-final by Fedora user juliuxpigface using the blocker tracking app because:

 In my opinion, it makes the "QA:Testcase_desktop_panel_advanced" fail. Since 'airplane mode' it's a very common option, I think it should be fixed before the final Fedora 22 reaches the light. The release criteria it violates is here: https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria#Default_panel_functionality

Comment 2 Jan Grulich 2015-03-30 08:05:02 UTC
Airplane mode turns off only mobile broadband, wifi and bluetooth, that's all, your ethernet should still work. I don't see a problem here.


Note You need to log in before you can comment on or make changes to this bug.