Bug 120677 - X resource leakage
X resource leakage
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 18:03 EDT by Mathieu Chouquet-Stringer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 08:09:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mathieu Chouquet-Stringer 2004-04-12 18:03:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.14

Description of problem:
Not too long ago Bill Nottingham added xrestop to Fedora so we/he
could track application leaking resources.

Using GNUS (as a newsreader), it appears that emacs leaks a lot of
resources when it displays images internally (inside its window
instead of launching eog). The more images it displays the more memory
it uses.

Here's the output of xrestop for an instance of emacs that has been up
for 2 days:
xrestop - Display: localhost:0
          Monitoring 20 clients. XErrors: 0
          Pixmaps:  190071K total, Other:     136K total, All: 
190207K total

res-base Wins  GCs Fnts Pxms Misc   Pxm mem  Other   Total   PID
Identifier
1a00000     8   84    6  158  133   177726K     11K 177737K   ?  
emacs@mcs

Version-Release number of selected component (if applicable):
emacs-21.3-11

How reproducible:
Always

Steps to Reproduce:
1. Start emacs
2. Go on usenet and reads some binaries forums (for me it's
alt.binaries.pictures.aviation)
3. Look at emacs eating your memory
    

Additional info:
Comment 1 Jens Petersen 2004-04-14 04:44:49 EDT
Any better with cvs emacs?
Comment 2 Jens Petersen 2004-04-14 04:45:34 EDT
in particular with gtk2 support
Comment 3 Mathieu Chouquet-Stringer 2004-04-14 09:40:12 EDT
Ok, just got cvs emacs this morning, compiled it using "configure
--with-gtk && setarch i386 make bootstrap" and the problem is still
present.
Comment 4 Jens Petersen 2004-04-15 10:44:39 EDT
Thanks for testing with cvs Emacs too. :-)

I recommend reporting this issue upstream: eg on emacs-devel.

Note You need to log in before you can comment on or make changes to this bug.