Bug 120682 - X works if I login as root
X works if I login as root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-12 18:31 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 15:41:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-04-12 18:31:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040316

Description of problem:
X works if I login  as root,
it also works if I change rights by
su user

X do not work if I login as user,
it only shows old ikons, prepared by redhat-9,
trying to open in shell, for example by
'mozilla' the usual response is 'floating point'

I did try to install FC2-test2,
no possibility,
because may CDROM does not works CD-install any sort,
my XP-prof does not have proper dos
and kernel 2.6 is to big for a floppy

Unfortunatrly X is not convenient for normal work.
so trying to improve I achieded opposite result,
unless sombody can help me 


Version-Release number of selected component (if applicable):
upgraded from redhat-9

How reproducible:
Always

Steps to Reproduce:
1.upgrade redhat-9 by fedora core 1 'yarrow'
2.login as user
3.you see just old ikons that do not work,
trying by command 'floating point' as usuall
4. login as root,
all works but not conveniently 
    

Actual Results:  X works if login as root 
X do'nt work if login as user

Expected Results:  X works in both cases,
but is friendly if login as user

Additional info:

I can't do anything by X if login as user,
if login as root all is normal
I will do all the necessary tests  
on request and will report the results
immediately
Comment 1 Need Real Name 2004-04-12 21:00:56 EDT
if I login as root and then change rights by
su user, then :

$ Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kedit: cannot connect to X server :0
Comment 2 Mike A. Harris 2004-04-13 15:41:16 EDT
This is a technical support request rather than a bug report.  Please
use Red Hat mailing lists for such problems, not bugzilla.  X works
fine as non-root unless you've broken something in your local
installation or configuration.

Closing as NOTABUG.
Comment 3 Need Real Name 2004-04-14 02:25:49 EDT
I agree abut the local configuration,
I was writing abot this because the trouble satred just after upgrading
redhat-9 to fedora-1 automatically by annacionda without my
interfetrence, 
to my mind
that means  redhat-9 is less sensitive to same configuration 
irregularities
what is not a bad feature

Note You need to log in before you can comment on or make changes to this bug.